Bug#651554: totem-plugins: totem segfault in gdata via grilo

Alban Browaeys prahal at yahoo.com
Fri Dec 9 21:36:41 UTC 2011

Package: totem-plugins
Version: 3.2.1-1
Severity: normal

Dear Maintainer,

I fixed this segfault :
Program received signal SIGSEGV, Segmentation fault.
0x00007fffc5009c14 in gdata_youtube_service_new () from /usr/lib/libgdata.so.13
(gdb) bt
#0  0x00007fffc5009c14 in gdata_youtube_service_new () from /usr/lib/libgdata.so.13
#1  0x00007fffc0a4ad6c in grl_youtube_plugin_init () from /usr/lib/grilo-0.1/libgrlyoutube.so
#2  0x00007fffc146a29f in grl_plugin_registry_load () from /usr/lib/libgrilo-0.1.so.0
#3  0x00007fffc146a529 in ?? () from /usr/lib/libgrilo-0.1.so.0
#4  0x00007fffc146a6bd in grl_plugin_registry_load_all () from /usr/lib/libgrilo-0.1.so.0
#5  0x00007fffc168dfb0 in ?? () from /usr/lib/totem/plugins/grilo/libgrilo.so
#6  0x00007ffff1437804 in g_closure_invoke (closure=0x613310, return_value=0x0, n_param_values=3, param_values=0x1c754f0, 
    invocation_hint=<optimized out>) at /tmp/buildd/glib2.0-2.30.2/./gobject/gclosure.c:774
#7  0x00007ffff144978a in signal_emit_unlocked_R (node=<optimized out>, detail=0, instance=0x7fffdc0350c0, emission_return=0x0, 
    instance_and_params=0x1c754f0) at /tmp/buildd/glib2.0-2.30.2/./gobject/gsignal.c:3272
#8  0x00007ffff1452e11 in g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, 
    var_args=<optimized out>) at /tmp/buildd/glib2.0-2.30.2/./gobject/gsignal.c:3003
#9  0x00007ffff1452fb2 in g_signal_emit (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>)
    at /tmp/buildd/glib2.0-2.30.2/./gobject/gsignal.c:3060
#10 0x00007ffff1437804 in g_closure_invoke (closure=0x141d300, return_value=0x0, n_param_values=2, param_values=0x1ccf190, 
    invocation_hint=<optimized out>) at /tmp/buildd/glib2.0-2.30.2/./gobject/gclosure.c:774
#11 0x00007ffff1449955 in signal_emit_unlocked_R (node=<optimized out>, detail=0, instance=0x118c820, emission_return=0x0, instance_and_params=
    0x1ccf190) at /tmp/buildd/glib2.0-2.30.2/./gobject/gsignal.c:3342
#12 0x00007ffff1452e11 in g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, 
    var_args=<optimized out>) at /tmp/buildd/glib2.0-2.30.2/./gobject/gsignal.c:3003
#13 0x00007ffff1452fb2 in g_signal_emit (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>)
    at /tmp/buildd/glib2.0-2.30.2/./gobject/gsignal.c:3060
#14 0x00007ffff18b181a in peas_engine_set_loaded_plugins () from /usr/lib/libpeas-1.0.so.0
#15 0x00007ffff143fe72 in object_set_property (nqueue=0x7fffdc042200, value=0x7fffffffd5f0, pspec=0x118ced0, object=0x118c820)
    at /tmp/buildd/glib2.0-2.30.2/./gobject/gobject.c:1199
#16 g_object_set_property (object=0x118c820, property_name=<optimized out>, value=0x7fffffffd5f0)
    at /tmp/buildd/glib2.0-2.30.2/./gobject/gobject.c:1929
#17 0x00007ffff30dabed in g_settings_binding_key_changed (settings=<optimized out>, key=<optimized out>, user_data=0x135aaa0)
    at /tmp/buildd/glib2.0-2.30.2/./gio/gsettings.c:2615
#18 0x00007ffff30dd55f in g_settings_bind_with_mapping (settings=0x118cf20, key=0x7ffff7bc614f "active-plugins", object=0x118c820, property=
    0x7ffff7bc6140 "loaded-plugins", flags=<optimized out>, get_mapping=0, set_mapping=0, user_data=0x0, destroy=0)
    at /tmp/buildd/glib2.0-2.30.2/./gio/gsettings.c:2921
#19 0x00007ffff30dd91c in g_settings_bind (settings=<optimized out>, key=<optimized out>, object=<optimized out>, property=<optimized out>, 
    flags=<optimized out>) at /tmp/buildd/glib2.0-2.30.2/./gio/gsettings.c:2742
#20 0x00007ffff7ba61b1 in totem_plugins_engine_get_default () from /usr/lib/libtotem.so.0
---Type <return> to continue, or q <return> to quit---
#21 0x00007ffff7b8f185 in totem_object_plugins_init () from /usr/lib/libtotem.so.0
#22 0x0000000000402fc2 in _start ()

by rebuilding grilo-plugins-0.1 against libgdata13 (0.10) . Current grilo plugins are compiled against
libgdata11 (0.8) while totem-plugins 3.2.1 is compiled against liibgdata13.
(I have both libgdata11 and 13 installed).

>From the above trace we see that libgdata13 is used by grilo on the above setup when called via
totem-plugins even though as seen grilo plugins are build against libgdata11. Segfault ensue.

Would there be a mean to avoid totem-plugins and grilo to mix conflicting api at least for gdata ?
Is this an issue in libgdata , totem-plugins, grilo-plugins or else ?

Again a rebuild of grilo-plugins against libgdata13 and the issue vanish. Totem 3.2 no longer segfault.

Best regards,

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.1.0test0 (SMP w/2 CPU cores)
Locale: LANG=fr_FR.utf8, LC_CTYPE=fr_FR.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages totem-plugins depends on:
ii  gir1.2-gdkpixbuf-2.0             2.24.0-1
ii  gir1.2-glib-2.0                  1.31.0-2
ii  gir1.2-gtk-3.0                   3.2.2-3
ii  gir1.2-pango-1.0                 1.29.4-2
ii  gir1.2-peas-1.0                  1.2.0-1
ii  gir1.2-totem-1.0                 3.2.1-1
ii  libatk1.0-0                      2.2.0-2
ii  libavahi-client3                 0.6.30-5
ii  libavahi-common3                 0.6.30-5
ii  libavahi-glib1                   0.6.30-5
ii  libbluetooth3                    4.96-3
ii  libc6                            2.13-21
ii  libcairo-gobject2                1.10.2-6.1
ii  libcairo2                        1.10.2-6.1
ii  libclutter-1.0-0                 1.8.2-2
ii  libclutter-gst-1.0-0             1.4.2-1
ii  libclutter-gtk-1.0-0             1.0.4-1
ii  libcogl-pango0                   1.8.2-1
ii  libcogl5                         1.8.2-1
ii  libdbus-1-3                      1.5.8-1
ii  libdbus-glib-1-2                 0.98-1
ii  libdrm2                          2.4.28-1
ii  libepc-1.0-3                     0.4.3-1
ii  libepc-ui-1.0-3                  0.4.3-1
ii  libffi5                          3.0.10-3
ii  libfontconfig1                   2.8.0-3
ii  libfreetype6                     2.4.8-1
ii  libgdata13                       0.10.1-1
ii  libgdk-pixbuf2.0-0               2.24.0-1
ii  libgirepository-1.0-1            1.31.0-2
ii  libgl1-mesa-glx [libgl1]         7.11.1-1
ii  libglib2.0-0                     2.30.2-4
ii  libgrilo-0.1-0                   0.1.17-1
ii  libgstreamer-plugins-base0.10-0  0.10.35-1
ii  libgstreamer0.10-0               0.10.35-1
ii  libgtk-3-0                       3.2.2-3
ii  libice6                          2:1.0.7-2
ii  libjson-glib-1.0-0               0.14.2-1
ii  liblircclient0                   0.9.0~pre1-1
ii  libmx-1.0-2                      1.4.1-1
ii  libpango1.0-0                    1.29.4-2
ii  libpeas-1.0-0                    1.2.0-1
ii  libsm6                           2:1.2.0-2
ii  libsoup2.4-1                     2.36.1-1
ii  libtotem-plparser17              2.32.6-1
ii  libtotem0                        3.2.1-1
ii  libx11-6                         2:1.4.4-4
ii  libxcomposite1                   1:0.4.3-2
ii  libxdamage1                      1:1.1.3-2
ii  libxext6                         2:1.3.0-3
ii  libxfixes3                       1:5.0-4
ii  libxi6                           2:1.4.3-3
ii  libxml2                          2.7.8.dfsg-5
ii  libxtst6                         2:1.2.0-4
ii  python                           2.7.2-9
ii  python-beautifulsoup             3.2.0-2
ii  python-feedparser                5.0.1-1
ii  python-gi                        3.0.2-4
ii  python-httplib2                  0.7.2-1
ii  python-xdg                       0.19-3
ii  python2.7                        2.7.2-8
ii  totem                            3.2.1-1

Versions of packages totem-plugins recommends:
pn  gnome-settings-daemon  3.2.2-1
pn  totem-coherence        <none>

Versions of packages totem-plugins suggests:
ii  gromit  20041213-9

-- no debconf information

More information about the pkg-gnome-maintainers mailing list