Bug#652109: python-nautilus: Cannot be initialized by Nautilus

Michael Biebl biebl at debian.org
Wed Dec 14 21:48:45 UTC 2011

severity 652109 serious
tags 652109 - upstream

On 14.12.2011 22:17, Louis wrote:
> Package: python-nautilus
> Version: 1.1-2
> Severity: grave
> Tags: upstream
> Justification: renders package unusable
> Hello,
> since update of python-nautilus to version 1.1-2, it cannot be initialized by
> Nautilus, rendering applications using it useless.
> When running nautilus, the following messages appears :
> (nautilus:6756): Nautilus-Python-WARNING **: pygobject initialization failed
> (nautilus:6756): Nautilus-Python-WARNING **: nautilus_python_init_python failed
> Nautilus is then launched and seems to work properly, excepted that extensions
> relying on this library (e.g. nautilus-compare) have disappeared (it is as if
> they were not installed).

> ii  python-gobject [python-gi]  2.28.6-5  

python-nautilus needs python-gi >= 3.0, not the virtual package that is
provided by the old statics binding package.
It's unfortunate, that the old python-gobject package does provide
python-gi, so we need versioned depends.

As soon as the current python-gi from unstable migrates to testing,
python-nautilus should be working again.
Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 900 bytes
Desc: OpenPGP digital signature
URL: <http://lists.alioth.debian.org/pipermail/pkg-gnome-maintainers/attachments/20111214/19d551e3/attachment.pgp>

More information about the pkg-gnome-maintainers mailing list