Bug#645845: gnome-control-center: speaker testing fails silently if pulse is installed but libcanberra-pulse is not installed

Daniel Kahn Gillmor dkg at fifthhorseman.net
Wed Oct 19 02:55:02 UTC 2011

Package: gnome-control-center
Version: 1:3.0.2-3
Severity: normal

I'm running an up-to-date sid system, with gnome and pulseaudio
installed.  paplay is capable of playing audio directly from the
command line.

poking around in the gnome system settings panel, i looked at the
sound settings.  in the hardware tab there is a "test speakers"

This brings up a dialog box titled "Speaker Testing for
SoundByLayout", which shows two speakers (labeled "Front Left" and
"Front Right") flanking a happy face (which is supposed to be me, i
guess).  Under each speaker is a button labeled "Test".  Clicking
these buttons doesn't appear to have any effect.

I straced the gnome-control-center process to see what was happening
when i clicked the "Test" button and found it was trying to load
/usr/lib/libcanberra-0.28/libcanberra-pulse.la or
/usr/lib/libcanberra-0.28/libcanberra-pulse.so, neither of which was
installed on my system.

I installed libcanberra-pulse, and suddenly the test buttons caused
audio to come out of my speakers.

If the needed audio library cannot be loaded, then the test
application should indicate what it is missing, rather than silently
producing no output.

I'm attaching a chunk of strace output from a time when
libcanberra-pulse is not installed, and during which time i switched
to the sound testing window, and triggered the "test" button by
hitting spacebar, and then switched away from the window again.

At the very least, this scenario should result in a warning to the
user about the missing library instead of leaving the user thinking
something is broken in their speakers.


-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: powerpc (ppc)

Kernel: Linux 3.0.0-2-powerpc
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages gnome-control-center depends on:
ii  accountsservice            0.6.14-1             
ii  apg                        2.2.3.dfsg.1-2       
ii  desktop-file-utils         0.15-2               
ii  gnome-control-center-data  1:3.0.2-3            
ii  gnome-desktop3-data        3.0.2-2              
ii  gnome-icon-theme           3.2.1-1              
ii  gnome-icon-theme-symbolic  3.2.1-1              
ii  gnome-menus                3.0.1-2              
ii  gnome-settings-daemon      3.0.3-3              
ii  gsettings-desktop-schemas  3.0.1-1              
ii  libatk1.0-0                2.2.0-2              
ii  libc6                      2.13-21              
ii  libcairo-gobject2          1.10.2-6.1           
ii  libcairo2                  1.10.2-6.1           
ii  libcanberra-gtk3-0         0.28-2               
ii  libcanberra0               0.28-2               
ii  libcomerr2                 1.42~WIP-2011-10-16-1
ii  libcups2                   1.5.0-8              
ii  libdbus-1-3                1.4.16-1             
ii  libdbus-glib-1-2           0.98-1               
ii  libfontconfig1             2.8.0-3              
ii  libfreetype6               2.4.6-2              
ii  libgconf2-4                2.32.4-1             
ii  libgcrypt11                1.5.0-3              
ii  libgdk-pixbuf2.0-0         2.24.0-1             
ii  libglib2.0-0               2.28.8-1             
ii  libgnome-control-center1   1:3.0.2-3            
ii  libgnome-desktop-3-0       3.0.2-2              
ii  libgnome-menu2             3.0.1-2              
ii  libgnomekbd7               3.2.0-1              
ii  libgnutls26                2.12.11-1            
ii  libgssapi-krb5-2           1.9.1+dfsg-3         
ii  libgtk-3-0                 3.0.12-2             
ii  libgtop2-7                 2.28.4-1             
ii  libk5crypto3               1.9.1+dfsg-3         
ii  libkrb5-3                  1.9.1+dfsg-3         
ii  libnm-glib4                0.9.0-2              
ii  libnm-util2                0.9.0-2              
ii  libpango1.0-0              1.29.4-1             
ii  libpolkit-gobject-1-0      0.102-1              
ii  libpulse-mainloop-glib0    1.0-4                
ii  libpulse0                  1.0-4                
ii  libstartup-notification0   0.12-1               
ii  libupower-glib1            0.9.14-1             
ii  libx11-6                   2:1.4.4-2            
ii  libxi6                     2:1.4.3-3            
ii  libxklavier16              5.1-2                
ii  libxml2                    2.7.8.dfsg-5         
ii  zlib1g                     1:     

Versions of packages gnome-control-center recommends:
ii  gnome-session      3.0.2-3  
ii  gnome-user-guide
ii  iso-codes          3.29-1   
ii  mousetweaks        3.2.0-1  
ii  policykit-1-gnome  0.102-2  

Versions of packages gnome-control-center suggests:
ii  gnome-screensaver         3.0.1-1  
ii  gstreamer0.10-pulseaudio  0.10.30-1
ii  libcanberra-gtk-module    0.28-2   
ii  x11-xserver-utils         7.6+3    

-- no debconf information

More information about the pkg-gnome-maintainers mailing list