Bug#646056: vte: Should python-vte depend on gir1.2-vte-2.90?

Tobias Hansen tobias.han at gmx.de
Thu Oct 20 21:40:48 UTC 2011

Package: vte
Version: 0.28.2-1
Severity: normal

Dear Maintainer,

gedit-r-plugin uses vte and depends on python-vte.
Now I noticed that it doesn't work if gir1.2-vte-2.90
is not installed. It outputs this error:

ERROR:root:Could not find any typelib for Vte
Traceback (most recent call last):
  File "/usr/lib/gedit/plugins/RCtrl.py", line 45, in <module>
    from gi.repository import GObject, Gedit, Gtk, Gdk, GdkPixbuf, Vte, GLib, Pango, GtkSource
ImportError: cannot import name Vte

Now, should python-vte depend (directly or indirectly) on gir1.2-vte-2.90
or should gedit-r-plugin depend on it directly?

Best regards,
Tobias Hansen

More information about the pkg-gnome-maintainers mailing list