Bug#656564: libglib2.0-0: since upgrade to 2.30.2-5 programs start segfaulting at random

Daniel C. Klauer daniel.c.klauer at web.de
Sat Jan 28 14:33:36 UTC 2012

Hello all,

Attached is a core dump from a gnome-settings-daemon crash, this one is
with libglib2.0-0 2.30.2-6 installed.

Before that, I also tried running for a while with libglib2.0-0
downgraded to 2.30.2-4, but didn't see a crash then.

Additionally, no matter whether using -4, -5 or -6, sometimes I could
see gnome-settings-daemon aborting, and one of the following messages
appeared in .xsession-errors:

assertion failed: (0 <= index && index < 24)

assertion failed: (0 <= index && index < 24)

assertion failed: (0 <= index && index < 24)

These don't appear when it crashes, but perhaps that's the same problem.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: gnome-session-daemon-core-file.tar.xz
Type: application/octet-stream
Size: 909632 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/pkg-gnome-maintainers/attachments/20120128/20f7b35a/attachment-0001.obj>

More information about the pkg-gnome-maintainers mailing list