Bug#671690: libgamin0 breaks courier-imap/courier-imap-ssl (Sudden termination of connection)

Benny Baumann BenBE at geshi.org
Sat May 5 23:01:03 UTC 2012

Package: libgamin0
Version: 0.1.10-4
Severity: critical
Justification: breaks unrelated software

Dear Maintainer,

   * What led up to the situation?
I've been running a Courier IMAP and POP3 server on my system for quite some time which worked 
just fine except for some mail clients reporting "filesystem errors" when it was still running 
with some (older) libfam0 version. Replacing that libfam0 version by libgamin0 (which claims 
compatibility) worked fine and fixed the aforementioned problem at that time.

   * What exactly did you do (or not do) that was effective (or
I recently updated the Courier IMAP server from 4.8 to 4.10. After this logins to IMAP stopped 
working. As I expected a problem with the most recent courier-imap(-ssl) update I tried a 
downgrade to stable (4.8) which didn't have any effect regarding this problem: Clients still 
could not login nor got an error message from the server.

Additionally I checked for a permission problem and thus tried to disable the addional sanity 
checks Courier performs when reading the Maildir. This didn't change anything either.

To reproduce I tried to create an IMAP account afresh in my mail client with proper settings 
for the login credentials but when trying to use IMAP it just hang a few seconds and then 
suddently terminated without providing a login status message (e.g. OK or error message). 
When switching IMAP for POP3 it just worked properly.

   * What was the outcome of this action?
The outcome was that using the Courier IMAP server was impossible since although I could login 
according to authdaemond clients kept on disconnecting.

After multiple hours of checking everything (including analyzing encrypted network traces, logfiles, 
various configurations, the answer to life the universe and everything ...) I incidentially tried 
to recompile Courier IMAP from source using
    apt-src install courier-imap-ssl
which insisted on installing (the previously broken) libfam0 package(s). Interestingly NOW 
libfam0 worked without File system errors reported by the client AND the login returned to a 
working state.

   * What outcome did you expect instead?
If libgamin0 claims to provide libfam0 it should behave like libfam0.

Oh and secondly I expected software to just work ;-)


-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.0.0-1-amd64 (SMP w/8 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libgamin0 depends on:
ii  gamin  0.1.10-4
ii  libc6  2.13-32

libgamin0 recommends no packages.

libgamin0 suggests no packages.

More information about the pkg-gnome-maintainers mailing list