[Debian GNUstep maintainers] Please give back gnustep-base

Yavor Doganov yavor at gnu.org
Thu May 13 11:59:29 UTC 2010

gnustep-base/1.19.3-2 failed to build on powerpc with the following

| gcc NSObject.m -c \
| 	      -MMD -MP -DGNUSTEP_TARGET_DIR=\".\" -DGNUSTEP_TARGET_CPU=\"ix86\" -DGNUSTEP_TARGET_OS=\"linux-gnu\" -DGNUSTEP_IS_FLATTENED=\"yes\" -DLIBRARY_COMBO=\"gnu-gnu-gnu\" -Wall -Wcast-align -DGNUSTEP -DGNUSTEP_BASE_LIBRARY=1 -DGNU_RUNTIME=1 -DGNUSTEP_BASE_LIBRARY=1 -D_REENTRANT -fPIC -g -Wall -DDEBUG -fno-omit-frame-pointer -DGSWARN -DGSDIAGNOSE -Wno-import -O2 -fno-strict-aliasing -fexceptions -fobjc-exceptions -D_NATIVE_OBJC_EXCEPTIONS -fgnu-runtime -fconstant-string-class=NSConstantString -I../Headers/Additions -I../Headers -I./. -I. -I/usr/include/GNUstep -I/usr/local/include/GNUstep -I/usr/include/libxml2 -I/usr/include -I/usr/local/include/GNUstep -I/usr/include/GNUstep \
| 	       -o obj/NSObject.m.o
| /tmp/ccNLiy2x.s: Assembler messages:
| /tmp/ccNLiy2x.s:10774: Error: symbol `incmodified' is already defined
| make[4]: *** [obj/NSObject.m.o] Error 1

I believe I have addressed the issue in -3.  However, -3 FTBFS'ed on
most of the buildds as it was uploaded together with a new version of
gnustep-make, and apparently its dependency on gnustep-common is
rather loose (I'll fix this in the next -make upload, and will request
the -wb-team to schedule give-backs for the failing archs).

But now that gnustep-make_2.4.0-1 is installed on powerpc, I'd really
appreciate if you can give back gnustep-base_1.19.3-3 right now,
because I'd like to address any eventual problem ASAP (it fixes severe
security issues that were very recently disclosed publicly, so the
plan was -2 to migrate to squeeze ASAP).


More information about the pkg-GNUstep-maintainers mailing list