[Debian GNUstep maintainers] gnustep-base upload and/or transition required?

Yavor Doganov yavor at gnu.org
Tue May 17 21:34:18 UTC 2011

tags 624928 = fixed-upstream

At Mon, 16 May 2011 20:00:59 -0700,
Matt Kraai wrote:
>  /usr/bin/ld: warning: libobjc.so.2, needed by /usr/lib/gcc/x86_64-linux-gnu/4.6.1/../../../../lib/libgnustep-base.so, may conflict with libobjc.so.3

Argh, it looks like I missed the moment when GCC 4.6 became the
default compiler; apologies for the slightly inadequate comments at

> When I build the package in wheezy, I see no such warning and the
> executables run fine.

Yep, that's because gcc-defaults hasn't migrated yet.
> Is a transition and/or new upload of gnustep-base required to fix
> this?

Definitely.  I suggest to upload 1.22.0 (which has proper support for
the 4.6 ObjC runtime) to experimental along with the rest of the
GNUstep stack and prepare for transition (combined gnustep-base +
gnustep-gui + libobjc).  We'll do the usual tests and fix all known
bugs in advance.

The alternative is to backport the support for the new runtime and
patch -base 1.20.2, then have only a libobjc2->3 transition.  Probably
doable, but too much work, and the result may end up binary
incompatible (in theory it should not, though).  It is also not a very
motivating job considering a GNUstep transition is being planned

More information about the pkg-GNUstep-maintainers mailing list