[Debian GNUstep maintainers] Bug#672986: gnustep-gui-runtime: Multiple libobjc.so version linked due to mix of dependencies

Riccardo Mottola multix at gmail.com
Tue May 15 08:58:15 UTC 2012

Package: gnustep-gui-runtime
Version: 0.20.0-3
Severity: grave
Justification: renders package unusable

Dear Maintainer,

gnustep-base, gnustep-gui and gnustep-back depend on different version
of libobjc (libobjc.so.3 and libobjc.so.4 of gcc 4.6 and gcc 4.7

Since several GNUstep applications do crash, I suppose all recently
compiled applications (self-compiled ones but also Gorm, which got
recently updated and for which a separate bug is pending).

checking with ldd, if libobjc.so.3 comes before .so.4 ("old app") the
app will work, if .so.4 comes before, the applicationwill crash.
I think it is not a good idea that gnustep-core packages
(base,gui,back) depend on different libobjc runtimes.

I have installed:
gnustep-back0.20-cairo               0.20.1-2+b1
libgnustep-base1.22                  1.22.1-2+b1
libgnustep-gui0.20                   0.20.0-3

it appears that only "gui" was updated to newer libobjc.

This makes gnustep unusable for any "new" package and for any
self-compiled apps for development.

A ldd output of a working application:
        linux-gate.so.1 =>  (0xb76fe000)
        libGNUMail.so.1 => /usr/lib/gnumail.app/libGNUMail.so.1 (0xb75b4000)
        libgnustep-gui.so.0.20 => /usr/lib/libgnustep-gui.so.0.20 (0xb7153000)
        libgnustep-base.so.1.22 => /usr/lib/libgnustep-base.so.1.22 (0xb6ce7000)
        libobjc.so.3 => /usr/lib/i386-linux-gnu/libobjc.so.3 (0xb6cc7000)
        libc.so.6 => /lib/i386-linux-gnu/i686/cmov/libc.so.6 (0xb6b6a000)
        libPantomime.so.1.2 => /usr/lib/libPantomime.so.1.2 (0xb6aca000)
        libAddresses.so.0 => /usr/lib/libAddresses.so.0 (0xb6a9b000)
        libAddressView.so.0 => /usr/lib/libAddressView.so.0 (0xb6a6e000)
        libm.so.6 => /lib/i386-linux-gnu/i686/cmov/libm.so.6 (0xb6a48000)
        libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xb6a2b000)
        libpng12.so.0 => /lib/i386-linux-gnu/libpng12.so.0 (0xb6a00000)
        libgif.so.4 => /usr/lib/libgif.so.4 (0xb69f7000)
        libtiff.so.4 => /usr/lib/i386-linux-gnu/libtiff.so.4 (0xb6991000)
        libjpeg.so.8 => /usr/lib/i386-linux-gnu/libjpeg.so.8 (0xb6958000)
        libobjc.so.4 => /usr/lib/i386-linux-gnu/libobjc.so.4 (0xb6940000)
        libpthread.so.0 => /lib/i386-linux-gnu/i686/cmov/libpthread.so.0 (0xb692

output of a broken application:
      linux-gate.so.1 =>  (0xb777b000)
        libgnustep-gui.so.0.20 => /usr/lib/libgnustep-gui.so.0.20 (0xb7318000)
        libgnustep-base.so.1.22 => /usr/lib/libgnustep-base.so.1.22 (0xb6eac000)
        libpthread.so.0 =>
/lib/i386-linux-gnu/i686/cmov/libpthread.so.0 (0xb6e93000)
        libobjc.so.4 => /usr/lib/i386-linux-gnu/libobjc.so.4 (0xb6e7b000)
        libm.so.6 => /lib/i386-linux-gnu/i686/cmov/libm.so.6 (0xb6e55000)
        libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xb6e37000)
        libc.so.6 => /lib/i386-linux-gnu/i686/cmov/libc.so.6 (0xb6cda000)
        libpng12.so.0 => /lib/i386-linux-gnu/libpng12.so.0 (0xb6cb0000)
        libgif.so.4 => /usr/lib/libgif.so.4 (0xb6ca7000)
        libtiff.so.4 => /usr/lib/i386-linux-gnu/libtiff.so.4 (0xb6c41000)
        libjpeg.so.8 => /usr/lib/i386-linux-gnu/libjpeg.so.8 (0xb6c07000)
        libobjc.so.3 => /usr/lib/i386-linux-gnu/libobjc.so.3 (0xb6be7000)
        libavahi-common.so.3 =>
/usr/lib/i386-linux-gnu/libavahi-common.so.3 (0xb6bd9000)
        libavahi-client.so.3 =>
/usr/lib/i386-linux-gnu/libavahi-client.so.3 (0xb6bc6000)
        libgnutls.so.26 => /usr/lib/i386-linux-gnu/libgnutls.so.26 (0xb6afd000)

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 3.2.0-2-686-pae (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages gnustep-gui-runtime depends on:
ii  gnustep-base-runtime                   1.22.1-2+b1
ii  gnustep-common [gnustep-fslayout-fhs]  2.6.2-2
ii  gnustep-gui-common                     0.20.0-3
ii  libao4                                 1.1.0-1.1+b1
ii  libaspell15                            0.60.7~20110707-1
ii  libc6                                  2.13-32
ii  libcups2                               1.5.2-11
ii  libflite1                              1.4-release-4
ii  libgcc1                                1:4.7.0-8
ii  libgnustep-base1.22                    1.22.1-2+b1
ii  libgnustep-gui0.20                     0.20.0-3
ii  libobjc4                               4.7.0-8
ii  libsndfile1                            1.0.25-4

gnustep-gui-runtime recommends no packages.

gnustep-gui-runtime suggests no packages.

-- no debconf information

More information about the pkg-GNUstep-maintainers mailing list