[Pkg-gnutls-maint] Bug#459295: libgnutls26-dbg: Conflicts with libgnutls13-dbg

Andreas Metzler ametzler at downhill.at.eu.org
Sat Jan 5 13:12:01 UTC 2008

On 2008-01-05 Guus Sliepen <guus at debian.org> wrote:
> Package: libgnutls26-dbg
> Version: 2.2.0-1
> Severity: serious
> Justification: Policy 3.9

> The libgnutlsXX-dbg packages do not only contain versions of the
> libraries with debugging symbols, but also unstripped binaries from the
> gnutls-bin package. This prevents multiple -dbg packages from being
> installed simultaneously:

> Selecting previously deselected package libgnutls26-dbg.
> Unpacking libgnutls26-dbg (from .../libgnutls26-dbg_2.2.0-1_amd64.deb) ...
> dpkg: error processing /var/cache/apt/archives/libgnutls26-dbg_2.2.0-1_amd64.deb (--unpack):
>  trying to overwrite `/usr/lib/debug/usr/bin/gnutls-cli', which is also
>  in package libgnutls13-dbg

> Either the -dbg packages should conflict with each other, or the
> unstripped binaries should be moved to a new package, for example
> gnutls-bin-dbg.

Thanks for catching that. I will add conflicts.
cu andreas
`What a good friend you are to him, Dr. Maturin. His other friends are
so grateful to you.'
`I sew his ears on from time to time, sure'

More information about the Pkg-gnutls-maint mailing list