[DebianGIS-dev] Bug#496861: josm should depend on openjdk-6-jre | jamvm | java2-runtime

Andreas Putzo andreas at putzo.net
Thu Aug 28 13:42:31 UTC 2008


On Aug 28  11:33, James Andrewartha wrote:
> The latest version of josm has a dependency only on openjdk-6-jre which
> means it can't be used with sun-java6-jre. I don't really want two JREs,
> and I need Sun Java for compatability reasons.

you can still use josm with Sun's Java if you set JAVA_HOME accordingly
or run josm with 
 JAVACMD= /usr/lib/jvm/java-6-sun/bin/java josm

There are currently many packages that provide java2-runtime, and josm
only works with few of them. That's why i prefer keeping the dependency
on openjdk and switch back to a virtual dependency as soon as we either
have better virtual packages for java runtimes or have the bugs fixed
that prevents josm from running with other javas.


More information about the Pkg-grass-devel mailing list