[DebianGIS-dev] Compiling issues with new JOSM versions

Andreas Putzo andreas at putzo.net
Sun May 18 21:51:04 UTC 2008


On May 18  18:05, Giovanni Mascellani wrote:
> Problems were not finished: Josm didn't compile, because it now relies
> on classes such as sun.net.www.protocol.http.Handler and
> sun.net.www.protocol.http.HttpURLConnection, which are present in
> official Sun compiler, but not in GCJ, which we are using.
Using the Sun class is a temporary workaround to support a body in
DELETE statements that should go away once diff uploads are implemented.

> So, the question is: should we move to Sun's javac, or do you know some
> workaround for this? I've just updated josm-plugins (which can't be
> build right now, because it depends on too recent josm) and josm (which
> fails to build for the reason I just underlined) to SVN.

I'd say let's wait until support for api 0.6 is properly implemented 
in josm and upload a new version then.

> Another word to Andreas: we're currently shipping josm-plugins under
> GPL-3+. Do you agree to move to GPL-2+ like we've done for josm?

Yes, of course :)


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://lists.alioth.debian.org/pipermail/pkg-grass-devel/attachments/20080518/01e0fe72/attachment.pgp 

More information about the Pkg-grass-devel mailing list