[DebianGIS-dev] Bug#537414: please default to 1.8 interface for hdf5-1.8.x

Francesco P. Lovergine frankie at debian.org
Mon Jul 20 12:14:19 UTC 2009

On Sat, Jul 18, 2009 at 12:21:19AM -0400, Chun-Chung Chen wrote:
> Package: hdf5
> Version: 1.8.3-1
> Severity: wishlist
> When default to 1.8 interface, building packages using 1.6 interface
> can be done with CFLAGS="-DH5_USE_16_API". However, there is no
> similar mechanism available for building packages using 1.8
> interface when 1.6 is the default. One will have to modify the
> source code manually for all occurrences of changed prototypes.

Preserving back-compatibility is the major concern. Applications
can always refer new functions by their explicit names or using
some better mechanism to work with both versions. The compatibility
macros are better suited for not up-to-date programs and the 1.6
API is the default one for non randomic reasons. I would avoid
to change the default behavior for the incoming years until
1.8 series would become of general use.

Francesco P. Lovergine

More information about the Pkg-grass-devel mailing list