[DebianGIS-dev] Bug#568271: qgis: circular dependency hell

Bill Allombert ballombe at debian.org
Wed Feb 3 15:49:54 UTC 2010

Package: qgis
Version: 1.4.0+12730-1
Severity: important

Hello Debian GIS Project,

qgis source package lead to 3 circular dependencies:

qgis <--> qgis-common,
python-qgis <--> python-qgis-common
qgis-plugin-grass <--> qgis-plugin-grass-common:

qgis 	        :Depends: qgis-common (= 1.4.0+12730-1)
qgis-common 	:Depends: qgis (>= 1.4.0+12730-1)
python-qgis 	:Depends: python-qgis-common (= 1.4.0+12730-1)
python-qgis-common 	:Depends: python-qgis (>= 1.4.0+12730-1)
qgis-plugin-grass 	:Depends: qgis (= 1.4.0+12730-1), qgis-plugin-grass-common (= 1.4.0+12730-1)
qgis-plugin-grass-common:Depends: qgis-plugin-grass (>= 1.4.0+12730-1)

Complex circular dependencies are known to cause problems during upgrade, so we
should try to get rid of them.

See threads 

Bill. <ballombe at debian.org>

Imagine a large red swirl here. 

More information about the Pkg-grass-devel mailing list