Bug#571259: gstreamer0.10-plugins-base: Logitech Quickcam Zoom stopped working with gstreamer-based apps

Marcus Lundblad ml at update.uu.se
Wed Feb 24 19:31:26 UTC 2010

Package: gstreamer0.10-plugins-base
Version: 0.10.26-1
Severity: normal

Since an update in Squeeze a couple of days ago all gstreamer-based apps has
stopped working with my webcam.
When trying f.ex. running the test in gstreamer-properties the following
lines are observed in dmesg:

[4837593.237443] pwc: isoc_init() submit_urb 0 failed with error -28
[4837593.237449] pwc: isoc_init() submit_urb 1 failed with error -28

This is the lsusb output for the cam:

Bus 003 Device 005: ID 046d:08b4 Logitech, Inc. QuickCam Zoom

If I use LD_PRELOAD to set v4l compat library, gstreamer-properties can show
the video when using the v4l plugin, like this:

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so gstreamer-properties

Other applications not using gstreamer, such as Camorama works without issues.


-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (900, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.30-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=sv_SE.UTF-8, LC_CTYPE=sv_SE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages gstreamer0.10-plugins-base depends on:
ii  libc6                    2.10.2-2        GNU C Library: Shared libraries
ii  libcdparanoia0           3.10.2+debian-9 audio extraction tool for sampling
ii  libglib2.0-0             2.22.4-1        The GLib library of C routines
ii  libgstreamer-plugins-bas 0.10.26-1       GStreamer libraries from the "base
ii  libgstreamer0.10-0       0.10.26-1       Core GStreamer libraries and eleme
ii  libgudev-1.0-0           151-2           GObject-based wrapper library for 
ii  libogg0                  1.1.4~dfsg-2    Ogg bitstream library
ii  liboil0.3                0.3.16-1        Library of Optimized Inner Loops
ii  libtheora0               1.1.1+dfsg.1-3  The Theora Video Compression Codec
ii  libvisual-0.4-0          0.4.0-2.1       Audio visualization framework
ii  libvorbis0a              1.2.3-3         The Vorbis General Audio Compressi
ii  libvorbisenc2            1.2.3-3         The Vorbis General Audio Compressi
ii  libx11-6                 2:1.3.3-1       X11 client-side library
ii  libxml2                  2.7.6.dfsg-2+b1 GNOME XML library
ii  libxv1                   2:1.0.5-1       X11 Video extension library

Versions of packages gstreamer0.10-plugins-base recommends:
ii  gvfs                          1.4.3-1    userspace virtual filesystem - ser

gstreamer0.10-plugins-base suggests no packages.

-- debconf-show failed

More information about the Pkg-gstreamer-maintainers mailing list