[hamradio-commits] [gnss-sdr] 147/303: Change name of L2C observables block

Carles Fernandez carles_fernandez-guest at moszumanska.debian.org
Mon Feb 13 22:35:56 UTC 2017


This is an automated email from the git hooks/post-receive script.

carles_fernandez-guest pushed a commit to branch master
in repository gnss-sdr.

commit e918da7785030ae0ca6efdf6554e84a98226f6e1
Author: Carles Fernandez <carles.fernandez at gmail.com>
Date:   Thu Nov 3 19:03:17 2016 +0100

    Change name of L2C observables block
---
 src/algorithms/observables/adapters/CMakeLists.txt     |  4 ++--
 ...{gps_l2_m_observables.cc => gps_l2c_observables.cc} | 16 ++++++++--------
 .../{gps_l2_m_observables.h => gps_l2c_observables.h}  | 18 +++++++++---------
 src/core/receiver/gnss_block_factory.cc                |  6 +++---
 4 files changed, 22 insertions(+), 22 deletions(-)

diff --git a/src/algorithms/observables/adapters/CMakeLists.txt b/src/algorithms/observables/adapters/CMakeLists.txt
index 3f3e95a..dcb40e5 100644
--- a/src/algorithms/observables/adapters/CMakeLists.txt
+++ b/src/algorithms/observables/adapters/CMakeLists.txt
@@ -18,9 +18,9 @@
 
 set(OBS_ADAPTER_SOURCES
 	gps_l1_ca_observables.cc
-	gps_l2_m_observables.cc
+	gps_l2c_observables.cc
 	galileo_e1_observables.cc
-     galileo_e5a_observables.cc
+    galileo_e5a_observables.cc
 	hybrid_observables.cc
 )
 
diff --git a/src/algorithms/observables/adapters/gps_l2_m_observables.cc b/src/algorithms/observables/adapters/gps_l2c_observables.cc
similarity index 85%
rename from src/algorithms/observables/adapters/gps_l2_m_observables.cc
rename to src/algorithms/observables/adapters/gps_l2c_observables.cc
index 59597eb..4ceffd1 100644
--- a/src/algorithms/observables/adapters/gps_l2_m_observables.cc
+++ b/src/algorithms/observables/adapters/gps_l2c_observables.cc
@@ -1,5 +1,5 @@
 /*!
- * \file gps_l2_m_observables.cc
+ * \file gps_l2c_observables.cc
  * \brief Implementation of an adapter of a GPS L2 C(M) observables block
  * to a ObservablesInterface
  * \author Carles Fernandez 2016. carles.fernandez(at)cttc.es
@@ -30,14 +30,14 @@
  */
 
 
-#include "gps_l2_m_observables.h"
+#include "gps_l2c_observables.h"
 #include "configuration_interface.h"
 #include <glog/logging.h>
 #include "GPS_L2C.h"
 
 using google::LogMessage;
 
-GpsL2MObservables::GpsL2MObservables(ConfigurationInterface* configuration,
+GpsL2CObservables::GpsL2CObservables(ConfigurationInterface* configuration,
         std::string role,
         unsigned int in_streams,
         unsigned int out_streams) :
@@ -56,11 +56,11 @@ GpsL2MObservables::GpsL2MObservables(ConfigurationInterface* configuration,
 }
 
 
-GpsL2MObservables::~GpsL2MObservables()
+GpsL2CObservables::~GpsL2CObservables()
 {}
 
 
-void GpsL2MObservables::connect(gr::top_block_sptr top_block)
+void GpsL2CObservables::connect(gr::top_block_sptr top_block)
 {
     if(top_block) { /* top_block is not null */};
     // Nothing to connect internally
@@ -68,20 +68,20 @@ void GpsL2MObservables::connect(gr::top_block_sptr top_block)
 }
 
 
-void GpsL2MObservables::disconnect(gr::top_block_sptr top_block)
+void GpsL2CObservables::disconnect(gr::top_block_sptr top_block)
 {
     if(top_block) { /* top_block is not null */};
     // Nothing to disconnect
 }
 
 
-gr::basic_block_sptr GpsL2MObservables::get_left_block()
+gr::basic_block_sptr GpsL2CObservables::get_left_block()
 {
     return observables_;
 }
 
 
-gr::basic_block_sptr GpsL2MObservables::get_right_block()
+gr::basic_block_sptr GpsL2CObservables::get_right_block()
 {
     return observables_;
 }
diff --git a/src/algorithms/observables/adapters/gps_l2_m_observables.h b/src/algorithms/observables/adapters/gps_l2c_observables.h
similarity index 83%
rename from src/algorithms/observables/adapters/gps_l2_m_observables.h
rename to src/algorithms/observables/adapters/gps_l2c_observables.h
index d73df87..aee598f 100644
--- a/src/algorithms/observables/adapters/gps_l2_m_observables.h
+++ b/src/algorithms/observables/adapters/gps_l2c_observables.h
@@ -1,5 +1,5 @@
 /*!
- * \file gps_l2_m_observables.h
+ * \file gps_l2c_observables.h
  * \brief Implementation of an adapter of a GPS L2C(M) observables block
  * to a ObservablesInterface
  * \author Carles Fernandez 2016. carles.fernandez(at)cttc.es
@@ -30,8 +30,8 @@
  */
 
 
-#ifndef GNSS_SDR_GPS_L2_M_OBSERVABLES_H_
-#define GNSS_SDR_GPS_L2_M_OBSERVABLES_H_
+#ifndef GNSS_SDR_GPS_L2C_OBSERVABLES_H_
+#define GNSS_SDR_GPS_L2C_OBSERVABLES_H_
 
 #include <string>
 #include "observables_interface.h"
@@ -41,25 +41,25 @@
 class ConfigurationInterface;
 
 /*!
- * \brief This class implements an ObservablesInterface for Galileo E1B
+ * \brief This class implements an ObservablesInterface for GPS L2C
  */
-class GpsL2MObservables : public ObservablesInterface
+class GpsL2CObservables : public ObservablesInterface
 {
 public:
-    GpsL2MObservables(ConfigurationInterface* configuration,
+    GpsL2CObservables(ConfigurationInterface* configuration,
             std::string role,
             unsigned int in_streams,
             unsigned int out_streams);
-    virtual ~GpsL2MObservables();
+    virtual ~GpsL2CObservables();
     std::string role()
     {
         return role_;
     }
 
-    //!  Returns "GPS_L2_M_Observables"
+    //!  Returns "GPS_L2C_Observables"
     std::string implementation()
     {
-        return "GPS_L2_M_Observables";
+        return "GPS_L2C_Observables";
     }
     void connect(gr::top_block_sptr top_block);
     void disconnect(gr::top_block_sptr top_block);
diff --git a/src/core/receiver/gnss_block_factory.cc b/src/core/receiver/gnss_block_factory.cc
index 894a3bf..b52d614 100644
--- a/src/core/receiver/gnss_block_factory.cc
+++ b/src/core/receiver/gnss_block_factory.cc
@@ -90,7 +90,7 @@
 #include "galileo_e5a_telemetry_decoder.h"
 #include "sbas_l1_telemetry_decoder.h"
 #include "gps_l1_ca_observables.h"
-#include "gps_l2_m_observables.h"
+#include "gps_l2c_observables.h"
 #include "galileo_e1_observables.h"
 #include "galileo_e5a_observables.h"
 #include "hybrid_observables.h"
@@ -1057,9 +1057,9 @@ std::unique_ptr<GNSSBlockInterface> GNSSBlockFactory::GetBlock(
                     out_streams));
             block = std::move(block_);
         }
-    else if (implementation.compare("GPS_L2_M_Observables") == 0)
+    else if (implementation.compare("GPS_L2C_Observables") == 0)
         {
-            std::unique_ptr<GNSSBlockInterface> block_(new GpsL2MObservables(configuration.get(), role, in_streams,
+            std::unique_ptr<GNSSBlockInterface> block_(new GpsL2CObservables(configuration.get(), role, in_streams,
                     out_streams));
             block = std::move(block_);
             }

-- 
Alioth's /usr/local/bin/git-commit-notice on /srv/git.debian.org/git/pkg-hamradio/gnss-sdr.git



More information about the pkg-hamradio-commits mailing list