[Pkg-ia32-libs-maintainers] Bug#493246: Bug#493246: ia32-libs-tools: does not support GNU/kFreeBSD

Petr Salinger Petr.Salinger at seznam.cz
Sat Aug 9 09:23:16 UTC 2008

> Have you tested if this works right? Installed a few packages and run
> them?

No, in fact I expect some problems in linux emulation, as our current 
FreeBSD kernel does not emulate futexes needed by nptl add-on.
But a kernel problem should not prevent ia32-libs-tools to offer 
installation of foreign (i386) packages for kfreebsd-i386 and 

> I'm unsure right now if kfreebsd is more like amd64 (has a libc6-i386)
> or like ia64 (needs ia32-libc6). Without checking I'm guessing it
> needs ia32-libc6 and would get it.

kfreebsd-amd64 w.r.t kfreebsd-i386 is like amd64 w.r.t i386
kfreebsd-amd64 w.r.t i386 is like ia64 w.r.t i386
kfreebsd-i386 w.r.t i386 is like ia64 w.r.t i386

IMHO, more valuable for kfreebsd-amd64 would be support
for linux/i386 binaries, it corresponds to "ia32-".

The patch should be 1st step in trying this.


More information about the Pkg-ia32-libs-maintainers mailing list