[Pkg-ia32-libs-maintainers] Bug#535425: ia32-libs-tools [...] builds for ia64 instead of amd64

Andreas Beckmann debian at abeckmann.de
Sat Jul 25 17:54:36 UTC 2009

Goswin von Brederlow wrote:
> The reason it builds for ia64 is that the ia32-libasound2 is only for
> ia64. On amd64 you already have lib32asound2 build from the source
> directly. Building it for amd64 would fail saying the architecture is
> not supported.

Uups, so I caught a bad example with libasound.

But there is another package that seems to be blacklisted incorrectly:

libstdc++5 (built from gcc-3.3) does not produce it's own ia32 package
but is blacklisted by the gcc-* pattern, so it does not build on amd64.
Changing the pattern to gcc-4* should be sufficient to fix this.

Then there is a case where version numbers in versioned depends must be
adjusted, too, if packages are renamed:

Package: libone
Version: 0.8-15

Package: libtwo
Version: 1.2-3
Depends: libone (<=> 0.8-15), pi (<=> 3.14)

after conversion:

Package: ia32-libone
Version: 0.8-15~23

Package: ia32-libtwo
Version: 1.2-3~23
Depends: ia32-libone (<=> 0.8-15~23), pi (<=> 3.14)

This is especially important if several library packages (that depend on
each other) are built from the same source, e.g. qt4-x11

Another question: to all generated ia32-libf00 (1.2.3-4~23) packages a
dependency on libf00 (= 1.2.3-4) is added. This should only be
neccessary is some files/scripts (e.g. manpages, config files,
translations) have been removed during creation of the ia32- package to
prevent file conflicts when both ia32-libf00 and libf00 are installed.
If no such conflict exists, it should be possible to have ia32-libf00
installed and working without having libf00 installed, too.
Or a Conflicts: libfoo (<< 1.2.3-4), libfoo (>> 1.2.3-4) would work to
forbid mismatching versions to be installed.


More information about the Pkg-ia32-libs-maintainers mailing list