[Pkg-ime-devel] scim svn changes: 1.0 branched, trunk follows 1.2 now

Ming Hua minghua@rice.edu
Tue, 12 Jul 2005 21:36:41 -0500

> Ming Hua wrote:
> >It seems scim 1.2.2 FTBFS with g++ 4.0.  The version 1.2.3 builds fine
> >though.  I've built 1.2.3 in updated sid environment but haven't tested
> >it yet (GNOME is broken here, perhaps due to mirror lag).
On Wed, Jul 13, 2005 at 12:53:21AM +0900, AWASHIRO Ikuya wrote:
> If you commit 1.2.3's debian directory, I will try to test.
> GNOME and KDE are broken on my environment, too. So I use xfce4.
> It works fine.

My GNOME breakage is due to gedit depending on libaspell15, but aspell
is recently rebuilt with GCC 4.0, and only libaspell15c2 exists now.  So
I just grabbed the old libaspell15 0.60.3-1 package, and installed
gnome-core just fine.

I've committed changes for 1.2.3 to SVN now.  The shared library package
name is changed to libscim6c2 according to the C++ transititon guide -
although there is no libscim6 package in official archive, I feel it
necessary to avoid problems with those 1.2 unofficial packages I built.
Be sure to Build-Depends on libscim-dev (>= 1.2.3) if you build new
module packages with these g++-4.0 built scim packages.

I tested my build with 1.2.3 (and XFree86 4.3.0, I've not upgraded to
Xorg yet), and it seems to be working fine.  I probably need to do one
more testing build after the Xorg upgrade though.

I would suggest not distributing these g++-4.0 built package yet, as it
may cause quite some confusion with the C++ ABI transition going on.
Awashiro-san, I suppose you build directly from SVN, if you need source
packages for testing, let me know.