Bug#342341: eclipse: too many unneeded dependencies

Erwan David erwan at rail.eu.org
Fri Dec 16 14:35:01 UTC 2005

Le Fri 16/12/2005, Billy Biggs disait
> On 16-Dec-05, at 3:19 AM, Erwan David wrote:
> >No eclipse (the software) depends on *gtk* libs. Even eclipse.org does
> >not cite gnome as a requirements. *YOU* impose gnome.
>   Erwan, what part about my description of our use of GNOME is
> confusing?
>   We use GNOME-VFS to implement the Program API.  It's used to:
>    - determine what your system web browser is
>    - determine what application should launch if you open
>      the "system editor" in eclipse
>    - actually run these programs
>   Without GNOME-VFS, the preferences dialog that lists web browsers
> won't list anything, nor will the listing of "external applications"
> for file associations, nor will the "open with > system editor" work,
> and any applications that depend on the SWT Program API will not
> work properly.
>   Do you want me to change the Eclipse Platform 3.2 plan on eclipse.org
> to more clearly state that we depend on gnome-vfs????  I can do
> this if it would help!

Yasd that would make easier for me to explain that eclipse is a
windows only thing

If you choose to make yoursellf dependant on people who claim that
"microsoft waéy is the only way to use a computer",be logical and make
windows only software.

Erwan David

More information about the pkg-java-maintainers mailing list