Bug#385257: No matching plugin was found

Eric Lavarde - Debian deb at zorglub.s.bawue.de
Wed Aug 30 07:47:49 UTC 2006

severity 385257 wishlist
retitle 385257 make-jpkg could detect EE Java and display helpful error text

Hi Giuseppe,

you've downloaded the EE (Enterprise/Server version), make-jpkg does only
work with Java SE (Desktop), so you need to download the Java SE JDK.

Alternatively, you can now use the sun-java5-* packages in
unstable/non-free; or of course use one of the free alternatives, kaffe,
gcj/gci ... (if it works for your application).

Nevertheless, make-jpkg could perhaps recognize the error and output a
more helpful message (perhaps by creating a minimal plugin, that would
just spit an error?!).

Cheers, Eric

> package: java-package
> version: 0.28
> priority: important
> I just installed an etch machine on a core duo, dowloaded
> java_ee_sdk-5-linux.bin from SUN site and run java-package. This is what
> happens now:
> giuseppe at scarafaggio:~/Desktop$ make-jpkg java_ee_sdk-5-linux.bin
> Creating temporary directory: /tmp/make-jpkg.lBkNf16863
> Loading plugins: blackdown-j2re.sh blackdown-j2sdk.sh common.sh
> ibm-j2re.sh ibm-j2sdk.sh j2re.sh j2sdk-doc.sh j2sdk.sh j2se.sh sun-j2re.sh
> sun-j2sdk-doc.sh sun-j2sdk.sh
> Detected Debian build architecture: i386
> Detected Debian GNU type: i486-linux-gnu
> No matching plugin was found.
> Removing temporary directory: done

Eric de France, d'Allemagne et de Navarre

More information about the pkg-java-maintainers mailing list