Bug#345677: eclipse: Eclipse doesn't start

Vedran Furač vedranf at vedranf.mine.nu
Thu Jan 5 19:48:08 UTC 2006

Stephan Michels wrote:
> On 1/3/06, Vedran Furač <vedranf at vedranf.mine.nu> wrote:
>>Arrgh, you can close this bug. The main reason I got these errors is
>>existence of redundant libswt-gtk-3.1-java package in the archive and
>>azureus depending on it. You should fix this ASAP.
> libswt-gtk-3.1-java is a separate package and has nothing to do with the
> Eclipse package. You shouldn't get problems if you install this package.
> Are you sure that Eclipse doesn't start if you install libswt-gtk-3.1-java?

It was my error. I didn't have neither libswt-gtk-3.1-java nor
libswt3.1-gtk-java package installed when I reported this bug.
Why I ended up without one of them installed, I'm not sure. I tried to
have both azureus and eclipse, which is currently not possible, see:
Azureus depends on libswt-gtk-3.1-java and eclipse depends on
libswt3.1-gtk-java. I tried to force install and somehow ended up without
libswt. Reinstalling libswt3.1-gtk-java package fixed the problem. You can
close this bug.

See if there is any problem in fixing those bugs with azureus maintainer,
so that eclipse and azureus can live together.

>>Also, I think that eclipse-source package isn't essential for eclipse.
> The org.eclipse.sdk feature depend on the source features and plugins.
> If we make this package optional, then we get complains from the framework.

I'm not expert in eclipse and never use it before. I thought that
eclipse-source and pde packages are required if I want to develop eclipse
or plugins and not if I only want to develop other applications *in* eclipse.

Vedran Furač

More information about the pkg-java-maintainers mailing list