Bug#369415: Needs java1-runtime, java2-runtime is not enough

Michael Koch konqueror at gmx.de
Thu Jun 1 21:42:06 UTC 2006

On Thu, Jun 01, 2006 at 02:24:55PM +0200, Arnaud Vandyck wrote:
> Hash: SHA1
> Marcin Owsiany a écrit :
> > What I meant is that maybe you could just add " | java2-runtime" after
> > "java1-runtime" to the Depends line for the time being? (That is, until
> > you change the current virtual package "mess".)
> I think virtual-package as no 'gender' (free/non-free) so we could add |
> java2-runtime. But we all know there is no package in main that provide
> java2-runtime, so it's like saying eclipse could run with non-free
> software. I don't know exactly if we can do that.
> Michael, what do you think? If you don't know, don't we have to ask on
> debian-devel?
> It'd be good to know before changing the policy so we could also say
> that a free package, able to run with free VM could have a depend line
> like: gij | classpath-runtime | java-runtime

debian-devel or debian-legal (or both).

Arnaud: Can you please do this? I'm on a customer site with limited
internet access and need to do a trip on weekend due to family issues.

Escape the Java Trap with GNU Classpath!

Join the community at http://planet.classpath.org/

More information about the pkg-java-maintainers mailing list