Bug#371062: Bug#371060: libgcj7-dev

Ben Burton bab at debian.org
Thu Jun 8 07:16:38 UTC 2006

> IMO its now the best time to get rid of this package totally.

FWIW, I'd forgotten that java-gcj-compat-dev even existed until your
mailout to d-d-announce last month ("GCJ 4.1 transition").  In this
mailout you ask maintainers of JNI packages to use
-I/usr/lib/jvm/java-gcj/include, which relies on symlinks provided
by java-gcj-compat and java-gcj-compat-dev.

Having said that, I don't particularly care if those packages stay or
go.  However, if they go then I'd love another mailout explaining the
new preferred long-term way of building against jni.h (or, if we are
meant to switch to relying on default include paths, some indication
that you plan to keep the gcc/gcj versions in sync).

Thanks - b.

More information about the pkg-java-maintainers mailing list