Bug#375872: libgtk-java has circular Depends on libgtk-jni

Bill Allombert ballombe at debian.org
Wed Jun 28 15:56:50 UTC 2006

Package: libgtk-java
Version: 2.8.4-1
Severity: important

Hello Debian Java maintainers,

There is a circular dependency between libgtk-java and libgtk-jni:

libgtk-java 	:Depends: libgtk-jni (= 2.8.4-1)
libgtk-jni 	:Depends: libgtk-java (= 2.8.4-1)

Circular dependencies involving libraries are known to cause problems
during upgrade between stable releases, so we should try to get rid of them.

See threads 

Bill. <ballombe at debian.org>

Imagine a large red swirl here. 

More information about the pkg-java-maintainers mailing list