Bug#388026: libgnome-java - FTBFS: error: Package requirements (gtk2-java >= 2.8) were not met

Steve Langasek vorlon at debian.org
Wed Sep 20 11:19:40 UTC 2006

tags 388026 patch

Since this is a regression introduced in an NMU, I'm skipping over the
waiting period and uploading a fix directly to incoming.  The patch for this
is attached.

With this patch, the package is again no longer binNMU-safe.  There are ways
to construct a binNMU-safe dep from an arch: all to an arch: any package,
but they're non-trivial and I think out of scope for this NMU.

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
vorlon at debian.org                                   http://www.debian.org/
-------------- next part --------------
diff -u libgtk-java-2.8.5/debian/control libgtk-java-2.8.5/debian/control
--- libgtk-java-2.8.5/debian/control
+++ libgtk-java-2.8.5/debian/control
@@ -9,7 +9,7 @@
 Package: libgtk-java
 Section: libs
 Architecture: all
-Depends: libglib-java, libcairo-java
+Depends: libglib-java, libcairo-java, libgtk-jni (= ${source:Version})
 Replaces: libgtk0-java, libgtk2-java
 Conflicts: libgtk2-java
 Description: GTK+ bindings for Java
@@ -37,7 +37,7 @@
 Package: libgtk-jni
 Section: libs
 Architecture: any
-Depends: ${shlibs:Depends}, libgtk-java (= ${source:Version})
+Depends: ${shlibs:Depends}
 Replaces: libgtk0-jni, libgtk2-jni
 Conflicts: libgtk2-jni
 Description: GTK+ bindings for Java
diff -u libgtk-java-2.8.5/debian/changelog libgtk-java-2.8.5/debian/changelog
--- libgtk-java-2.8.5/debian/changelog
+++ libgtk-java-2.8.5/debian/changelog
@@ -1,3 +1,15 @@
+libgtk-java (2.8.5-1.2) unstable; urgency=medium
+  * Non-maintainer upload.
+  * Medium-urgency upload for RC bugfix.
+  * Invert the circular dependency fix: libgtk-java uses libgtk-jni, but
+    not the reverse.  This fixes a number of build failures as well in 
+    packages build-depending on libgtk-java (closes: #388026).
+  * This means that the package is no longer binNMU-safe after all, but
+    this is the lesser of two evils.
+ -- Steve Langasek <vorlon at debian.org>  Wed, 20 Sep 2006 03:24:32 -0700
 libgtk-java (2.8.5-1.1) unstable; urgency=medium
   * Non-maintainer upload.

More information about the pkg-java-maintainers mailing list