Bug#420052: libgtk-java: FTBFS: 3 errors, 77 warnings during build

Thomas Girard thomas.g.girard at free.fr
Fri Apr 20 14:54:36 UTC 2007

tags 420052 + confirmed pending

Hello Lucas,

On Thu, Apr 19, 2007 at 07:01:50PM +0200, Lucas Nussbaum wrote:
> Package: libgtk-java
> Version: 2.8.5-1.2
> Severity: serious
> Justification: FTBFS on i386, very likely to fail everywhere else
> Usertags: grid5000 rebuild
> Hi,
> During a rebuild of all packages in sid, I discovered that your package
> failed to build on i386.
> Relevant parts:
> gcj -C -classpath
> "/usr/share/java/glib0.4-0.4.2.jar:/usr/share/java/cairo1.0-1.0.8.jar:src/java:./src/java
> " -d src/java src/java/org/gnu/glib/GObject.java
> src/java/org/gnu/glib/GObject.java:20: warning: The class
> 'org.gnu.glib.Struct' has been deprecated.
> public class GObject extends Struct {
> [....]
> 3 errors, 77 warnings
> make[1]: *** [src/java/org/gnu/glib/GObject.class] Error 1

Thanks for reporting this.

The libgtk-java distributed GObject.java had modifications over the one
from glib-java. Those modifications were merged back into glib-java;
from libgtk-java 2.9.1 on this file is no longer distributed along with

The problem here is that the Debian glib-java is up-to-date while
libgtk-java is not. I am currently updating all the Java Gnome 2.x
libraries and this issue will disappear when I'm done.



More information about the pkg-java-maintainers mailing list