Bug#407479: classpath: dependency on libgconf2-4 and libidl0 necessary?

Michael Koch konqueror at gmx.de
Thu Jan 18 22:15:07 UTC 2007

On Thu, Jan 18, 2007 at 08:35:48PM +0100, Michael Prokop wrote:
> Package: classpath
> Version: 2:0.92-4
> Severity: normal
> # apt-get install classpath
> Reading package lists... Done
> Building dependency tree... Done
> The following extra packages will be installed:
>   classpath-gtkpeer gconf2-common libgconf2-4 libidl0 liborbit2
> The following NEW packages will be installed:
>   gconf2-common libgconf2-4 libidl0 liborbit2
> The following packages will be upgraded:
>   classpath classpath-gtkpeer
> 2 upgraded, 4 newly installed, 0 to remove and 5 not upgraded.
> Need to get 0B/2630kB of archives.
> After unpacking 6992kB of additional disk space will be used.
> Is the new dependency on libgconf2-4 and libidl0 really necessary?
> Sorry, I could not find the reason in the changelog of classpath,
> or is it related to the 'Always build-depend on libxul-dev'?

Sorry for the incomplete changelog entry.

libgconf2-4 is used as backend for the java.util.preferences API.
This way you can easily exchange preference settings with non java
applications. libidl0 is just a dependency of libgconf2-4.

Please close this bug when the explanation is okay for you.

 .''`.  | Michael Koch <konqueror at gmx.de>
: :' :  | Free Java Developer <http://www.classpath.org>
`. `'   |
  `-    | 1024D/BAC5 4B28 D436 95E6 F2E0 BD11 5923 A008 2763 483B

More information about the pkg-java-maintainers mailing list