Bug#446299: eclipse: Crashes on startup

Jaanus Rõõmus jaanus at estsoft.ee
Thu Oct 11 20:05:21 UTC 2007

Package: eclipse
Version: 3.2.2-4
Severity: grave
Justification: renders package unusable

After running eclipse, startup dialog crashes on loading workbench and
shows error dialog:

JVM terminated. Exit code=1
-jar /usr/lib/eclipse/startup.jar
-os linux
-ws gtk
-arch x86_64
-launcher /usr/lib/eclipse/eclipse
-name Eclipse
-showsplash 600
-exitdata 3418028
-install /usr/lib/eclipse
-vm /usr/bin/java
-jar /usr/lib/eclipse/startup.jar 

In the console, I can see:

# An unexpected error has been detected by Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0x00002aaabd063e20, pid=7557, tid=1076017488
# Java VM: Java HotSpot(TM) 64-Bit Server VM (1.6.0_03-b05 mixed mode)
# Problematic frame:
# C  [libglib-2.0.so.0+0x22e20]
# An error report file with more information is saved as
# hs_err_pid7557.log
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages eclipse depends on:
ii  eclipse-jdt                   3.2.2-4    Java Development Tools plug-ins fo
ii  eclipse-pde                   3.2.2-4    Plug-in Development Environment to
ii  eclipse-source                3.2.2-4    Eclipse source code plug-ins
ii  zenity                        2.20.0-2   Display graphical dialog boxes fro

Versions of packages eclipse recommends:
pn  eclipse-gcj                   <none>     (no description available)

-- no debconf information

More information about the pkg-java-maintainers mailing list