Bug#542397: libtomcat6-java: upgrade fails, needs Conflict with older tomcat6-common

Marcus Better marcus at better.se
Wed Aug 19 13:26:47 UTC 2009

Package: libtomcat6-java
Version: 6.0.20-5
Severity: important

The symlink /usr/share/tomcat6/lib/jasper.jar appears to have moved
from tomcat6-common (in 6.0.20-2) to libtomcat6-java (in
6.0.20-5). Because of this, upgrades fail (excuse the Swedish):

Förbereder att ersätta libtomcat6-java 6.0.20-2 (med .../libtomcat6-java_6.0.20-5_all.deb) ...
Packar upp ersättande libtomcat6-java ...
dpkg: fel vid hantering av /var/cache/apt/archives/libtomcat6-java_6.0.20-5_all.deb (--unpack):
 försöker skriva över "/usr/share/tomcat6/lib/jasper.jar" som också finns i paketet tomcat6-common

Seems like libtomcat6-java needs a Conflicts with tomcat6-common (< 6.0.20-5).

Retrying the update succeeds, since by then the new tomcat6-common has
already been unpacked.

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=sv_SE.UTF-8, LC_CTYPE=sv_SE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libtomcat6-java depends on:
ii  default-jre-headless [java6-r 1.6-33     Standard Java or Java compatible R
ii  libcommons-dbcp-java          1.2.2-1    Database Connection Pooling Servic
ii  libcommons-pool-java          1.3-1      pooling implementation for Java ob
ii  libecj-java                   3.5-1      Eclipse Java compiler (library)
ii  libservlet2.5-java            6.0.20-5   Servlet 2.5 and JSP 2.1 Java API c
ii  openjdk-6-jre-headless [java6 6b16-4     OpenJDK Java runtime, using Hotspo

libtomcat6-java recommends no packages.

Versions of packages libtomcat6-java suggests:
pn  tomcat6                       <none>     (no description available)

-- debconf-show failed

More information about the pkg-java-maintainers mailing list