Bug#512443: Please enable a catalog resolver, or document how to do so

Joachim Breitner nomeata at debian.org
Tue Jan 20 21:27:20 UTC 2009

Package: fop
Version: 1:0.95.dfsg-2
Severity: wishlist

Hash: SHA1


I tried to make fop (the “binary”) to use the locally installed DTDs for
docbook, but I could not find out how.

I installed libxml-commons-resolver1.1-java, but I only could find
documentation on enabling this with xalan directly, and could not make
it work.

Ideally, fop would just use the Debian catalog in /etc/xml/catalog, or
at least document in the README.Debian how I can configure it to do so.


- -- System Information:
Debian Release: 5.0
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.27-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages fop depends on:
ii  java-gcj-compat [java2-ru 1.0.78-2       Java runtime environment using GIJ
ii  java-wrappers             0.1.11         wrappers for java executables
ii  libavalon-framework-java  4.2.0-4        Common framework for Java server a
ii  libbatik-java             1.7-1          xml.apache.org SVG Library
ii  libbsf-java               1:2.4.0-2      Bean Scripting Framework to suppor
ii  libcommons-io-java        1.4-1          Common useful IO related classes
ii  libcommons-logging-java   1.1.1-2        commmon wrapper interface for seve
ii  libxalan2-java            2.7.1-2        XSL Transformations (XSLT) process
ii  libxerces2-java           2.9.1-2        Validating XML parser for Java wit
ii  libxml-commons-external-j 1.3.04-1       XML Commons external code - DOM, S
ii  libxmlgraphics-commons-ja 1.3.1.dfsg-1   reusable components used by Batik 
ii  libxp6                    1:1.0.0.xsf1-2 X Printing Extension (Xprint) clie
ii  libxt6                    1:1.0.5-3      X11 toolkit intrinsics library
ii  libxtst6                  2:1.0.3-1      X11 Testing -- Resource extension 

fop recommends no packages.

Versions of packages fop suggests:
pn  fop-doc                       <none>     (no description available)
ii  libservlet2.4-java            5.0.30-8   Servlet 2.4 and JSP 2.0 Java class

- -- no debconf information

Version: GnuPG v1.4.9 (GNU/Linux)


More information about the pkg-java-maintainers mailing list