Bug#579504: antlr3: Typo in Python template renders python parser unusable

marc poulhies marc.poulhies at imag.fr
Wed Apr 28 06:06:30 UTC 2010

Package: antlr3
Version: 3.0.1+dfsg-4
Severity: normal
Tags: upstream

A typo in Python.stg (seperator instead of separator) displays a warning when
generating a python parser:
 warning(11):  internal warning: ignoring unsupported option: seperator
A simple patch to fix this is attached (this is fixed in up to date antlr)

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.33-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages antlr3 depends on:
ii  default-jre [java2-runtime]   1.6-36     Standard Java or Java compatible R
ii  default-jre-headless          1.6-36     Standard Java or Java compatible R
ii  gcj-4.4-jre [java2-runtime]   4.4.3-9    Java runtime environment using GIJ
ii  gcj-jre [java2-runtime]       4:4.4.3-1  Java runtime environment using GIJ
ii  jamvm [java1-runtime]         1.5.3-2    virtual machine which conforms to 
ii  libstringtemplate-java        3.1-4      StringTemplate templating engine f
ii  openjdk-6-jre [java2-runtime] 6b18-1.8-1 OpenJDK Java runtime, using Hotspo

Versions of packages antlr3 recommends:
ii  antlr3-gcj                  3.0.1+dfsg-4 language tool for constructing rec

antlr3 suggests no packages.

-- no debconf information
-------------- next part --------------
A non-text attachment was scrubbed...
Name: pythonfix.diff
Type: text/x-diff
Size: 961 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/pkg-java-maintainers/attachments/20100428/fba27c01/attachment.diff>

More information about the pkg-java-maintainers mailing list