Bug#587449: dpkg suggests to install gcj-* packages while Sun JRE is already installed

Dmitry Katsubo dma_k at mail.ru
Mon Jun 28 17:43:50 UTC 2010

Package: libjaxp1.3-java
Version: 1.3.04-3

Debian Release: sid

When I try to install this Java library, dpkg suggests to install gcj
environment packages, while sun-java6-jre package should be enough.

Expected: libjaxp1.3-java is installed without other dependencies.

# apt-get install libjaxp1.3-java
The following extra packages will be installed:
  gcj-4.4-base gcj-4.4-jre-lib libgcj-bc libgcj-common libgcj10
libjaxp1.3-java-gcj python-central

# dpkg -l | grep sun
ii  sun-java6-bin   6.20-dlj-1  Sun Java(TM) Runtime Environment (JRE) 6
(architecture depende
ii  sun-java6-jre   6.20-dlj-1  Sun Java(TM) Runtime Environment (JRE) 6
(architecture indepen

Relevant problem: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=583260

With best regards,

More information about the pkg-java-maintainers mailing list