Bug#610295: libcommons-net-java: New upstream : 2.2 / remove depdendency to oro

Mathieu Malaterre mathieu.malaterre at gmail.com
Mon Jan 17 09:13:33 UTC 2011

Package: libcommons-net-java
Version: 1.4.1-2
Severity: normal
Tags: upstream ipv6

It would be nice to update libcommons-net-java to latest upstream. It would:
- remove dep to oro lib
- add support for ipv6

Thanks !


Commons::Net now uses JDK regex functionality, saving on an extra [oro] dependency. There are now no external dependencies required.
Optionally enable EPSV with IPv4; Only send EPRT with IPv6. Fix incorrect port used with EPRT. Allow activeMaxPort == activeMinPort in getActivePort() method. Fixes NET-313.
Add support for IPv6 EPRT/EPSV Fixes NET-288.

-- System Information:
Debian Release: 6.0
  APT prefers testing
  APT policy: (200, 'testing'), (100, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libcommons-net-java depends on:
ii  default-jre-headless [java2 1:1.6-40     Standard Java or Java compatible R
ii  gcj-4.4-jre-headless [java2 4.4.5-2      Java runtime environment using GIJ
ii  gcj-jre-headless [java2-run 4:4.4.5-1    Java runtime environment using GIJ
ii  liboro-java                 2.0.8a-7     Regular expression library for Jav
ii  openjdk-6-jre-headless [jav 6b18-1.8.3-2 OpenJDK Java runtime, using Hotspo

libcommons-net-java recommends no packages.

libcommons-net-java suggests no packages.

-- no debconf information

More information about the pkg-java-maintainers mailing list