Bug#626020: more about Zookeeper
Henrique de Moraes Holschuh
hmh at debian.org
Sun Jun 12 14:27:26 UTC 2011
retitle 626020 zookeeper: incorrect dependency information
On Sun, 12 Jun 2011, Ted Dunning wrote:
> I just looked at this bug and it looks like a configuration error in
> the environment rather than a bug in Zookeeper per se.
> In particular, Java >= 1.6 is an explicit requirement of the Zookeeper
> package while the error being emitted is highly characteristic of an
> attempt to compile 1.6 compatible code on a java 1.5 compiler.
The Debian package declares:
Depends: libzookeeper-java (= 3.3.1+dfsg1-2), default-jre-headless | java6-runtime-headless, adduser
which looks like it would allow the package to be installed on java-5
environments at first glance. That would be a grave bug by itself.
It also declares:
Build-Depends: debhelper (>= 7.4.11), javahelper (>= 0.28), default-jdk (>=
1.6), ant (>= 1.6.0), liblog4j1.2-java (>> 1.2.15-8), junit4,
libxerces2-java, libjline-java, libnetty-java, javacc, default-jdk-doc,
python-all-dev, python-support, libboost-dev, libxml2-dev, liblog4cxx10-dev,
autoconf, help2man, libtool, automake, libcppunit-dev
Which is ALSO broken, due to the use of epochs in the default-jdk
versioning. It would have to declare a build-dependency on "default-jdk (>=
As it stands, it allows the package to be built under java-5, which appears
to be the reason for the FBTFS report from MIPS.
"One disk to rule them all, One disk to find them. One disk to bring
them all and in the darkness grind them. In the Land of Redmond
where the shadows lie." -- The Silicon Valley Tarot
More information about the pkg-java-maintainers