[Pkg-javascript-devel] libv8, nodejs status in collab-maint repository

Jérémy Lal jerry at edagames.com
Wed Nov 23 23:06:48 UTC 2011


libv8 is ready to be reviewed and uploaded to unstable.
The big change is the move to gyp-based building (but makefiles are
generated by upstream instead of regenerating them).

libv8 could also be uploaded to experimental, it's easier
to review because the changes since 3.5 are very straightforward.

nodejs 0.6.2, depends on libv8, is buildable.
It still needs debian/copyright work, and nodejs-dbg binary package is
broken (and removed from debian/control.in for now).
The big deception is 0.6 branch is still using waf as build system.
Even more messy is usage of custom versions of ev and cares in the new uv backend.
It might be impossible for now to make nodejs use the libev4 and libc-ares
packages, so uv backend uses its custom versions. 
There are some test failures, but it looks good nonetheless.

I'd appreciate reviews, advices about those packages.



More information about the Pkg-javascript-devel mailing list