[SCM] KDE Development Platform Libraries module packaging annotated tag, debian/4.2.0-1, created. debian/4.2.0-1

Modestas Vainius modax at alioth.debian.org
Mon Jul 26 16:22:35 UTC 2010

The annotated tag, debian/4.2.0-1 has been created
        at  c64938b5974b3a6f9c6b66f6b6d103f821137eac (tag)
   tagging  e258db1a12cb5f1828e5ce5ae8a07d24e16121d6 (commit)
  replaces  debian/4.1.3-2
 tagged by  Sune Vuorela
        on  Sun Jan 25 15:14:44 2009 +0000

- Shortlog ------------------------------------------------------------
4:4.2.0-1 experimental; urgency=low

Ana Beatriz Guerrero Lopez (29):
      Rework slightly patch 15_kfreebsd_support.diff.
      fixing patch breaking
      20_use_dejavu_as_default_font.diff (due to:
      update patch, fix build
      new file
      New snapshot post beta2.
      new file
      update file
      new snapshot and refresh patches
      new snapshot refreshing patches
      refresh patch
      refresh patch
      update patch. If somebody can comment what this patch is supposed to do is
      add patch comment
      remove stale file, rework a patch of file comments
      refresh patches
      finally rc1!
      renamed files
      new file and this seems being the latest change...
      new snapshot
      new snapshot, update b-d on phonon
      new files
      * Remove redudant section/priority fields in debian/control.
      forgot this
      updating version
      update just for the record
      kdelibs r3
      updating versions in changelogs and control all in one commit

Armin Berres (2):
      +++ Changes by Armin Berres:
      Add dependency on xdg-utils to kdelibs5. KDE applications use xdg-open to

Fathi Boudra (2):
      Bump depend on strigi 0.6.2-1
      Remove debian version

George Kiagiadakis (8):
      kdelibs needs to build-depend on a recent automoc
      New snapshot. Update kdelibs5-dev to depend on automoc >= 1.0~svn850570.
      Add the missing dot to make ana happy ;)
      Move development binaries from kdelibs-bin back to kdelibs5-dev, as
      New snapshot.
      New snapshot.
      New snapshot. Update plasma symbols and bump plasma-abi.
      New snapshot. Update installed files.

Modestas Vainius (63):
      Initial kdelibs 4.1.73+svn packaging.
      Make kdelibs5 conflict with kdebase-runtime << 4:4.1.73 because some
      Conflicts was stupid idea
      Some kde4libs fixes
      Make libplasma-dev depend on libqt4-opengl-dev
      New snapshot, some fixes
      libqt4-opengl-dev to build depends
      There is absolutely no reason for libplasma3 to conflict with libplasma2
      kdelibs update
      new kdelibs snapshot
      new kdelibs snapshot, some changes
      new snapshot
      new snapshot, installgen changes for -dev binaries
      libplasma3 - contains Plasma library and plugins. Make kdelibs5-dbg
      Lets get plasma ABI bumping party started
      Do not bump this time. Will do the next time
      Build depend on pkg-kde-tools 0.3~pre5, add symbols file for libplasma3,
      newer snapshot, fix amd64 build
      New snapshot
      Newer snapshot
      new snaphost, kdepimlibs mess
      New snapshot, update not-installed, refresh patches
      Commit a header for patch 17
      Add symbol
      New snapshot, no changes
      try to use plain upstream kdepimlibs cmake stuff
      Update libplasma3 symbols file
      Wee. Plasma ABI bump
      Plasma ABI fun
      Readd bug close
      newer kdelibs snapshot
      New libplasma symbol
      new snaphost, new plasma symbol
      Try to use common cmake config dir
      Support for common cmake options directory
      New snaphosts of core packages
      Newer snapshots of kde4libs and workspace. Should fix plasma-taskbar-cpu-eater bug
      New snapshots, plasma abi bump
      symbols file
      Newer snapshot, fixed double paste bug
      new plasma symbol
      Merge libplasma-dev to kdelibs5-dev
      Remove UiLoader from symbol file completely
      Add conflicts/replace for libplasma-dev
      double replaces
      Plasma ABI bump
      Correct plasma devel package
      kdelibs5-dev must depend on libplasma3
      Build depend on strigi 0.6.3
      extra comma
      plasma abi bump
      Newer snapshot, less buggy kdelibs
      TODO: remove plasma-abi-4.2-X for the first upload to the official
      archive (4:4.2.0-1). Not earlier. Also set all libplasma3
      Set libplasma3 symbol versions to 4:4.2.0
      Enforce higher soprano dependecy (b-d version is important when symbol files are used
      Massive *.lintian to *.lintian-overrides rename (with the exception of koffice)
      Massively migrate to debhelper v7. This allows to get rid DEB_DH_INSTALL_SOURCEDIR in kde.mk
      Revert debian/rules
      Update comment. Leave auto shlibs bumping ON
      This a huge commit which migrates all internal debian/cdbs "users" (with the

Sune Vuorela (4):
      +++ Changes by Sune Vuorela:
      Remove plasma abi handling. It is expected to be stable now.
      remove plasma-abi from symbols file as well


KDE Development Platform Libraries module packaging

More information about the pkg-kde-commits mailing list