[Pkg-kde-extras] Bug#391725: Bug#391721: beaglefs: change build dependency from beagle-dev to libbeagle-dev

Steve Langasek vorlon at debian.org
Tue Oct 17 09:43:02 UTC 2006

On Sun, Oct 15, 2006 at 11:55:43AM +0200, Jose Carlos Garcia Sogo wrote:
> > On Sun, Oct 08, 2006 at 12:47:49PM +0200, Jose Carlos Garcia Sogo wrote:
> > >   With latest upload of beagle (0.2.10-2) I have splitted beagle-dev in
> > >   two packages: old beagle-dev will only contain files needed for C#
> > >   development, while new libbeagle-dev will contain pieces needed for C
> > >   development. As I think you are only using libbeagle, you should
> > >   change your build dependencies to depend on libbeagle-dev.

> > Second, does the new beagle-dev not depend on libbeagle-dev?  That would
> > solve any release-critical transition issues here anyway.

>   There are only two packages with this problem: kerry and beaglefs. The
> idea is just not making libbeagle-dev dependant on beagle-dev, so it
> does not bring beagle itself. This way, people developing in C doesn't
> need even Mono installed.

Sure; but does the new beagle-dev depend on libbeagle-dev?  That would let
people developing in C switch to libbeagle-dev whenever it's convenient for
them, and continue to build-depend on beagle-dev in the meantime without
their packages being broken by this transition.  (And if the C# bindings
depend on the C library, it may be necessary regardless.)

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
vorlon at debian.org                                   http://www.debian.org/

More information about the pkg-kde-extras mailing list