[Pkg-kde-extras] Bug#507235: Bug#507235: libkipi6 from KDE4 conflicts with libkipi0

Artur R. Czechowski arturcz at hell.pl
Mon Apr 20 22:08:29 UTC 2009

On Tue, Apr 21, 2009 at 07:03:01AM +1000, Mark Purcell wrote:
> On Tuesday 21 April 2009 05:39:05 Artur R. Czechowski wrote:
> > kphotoalbum depends on libkipi0. KDE4 provides libkipi6 which conflicts
> > with libkipi0.
> This isn't actually a bug.
"That's not a bug, that's a feature" ;)

> kphotoalbum is currently a KDE3 application and is in the process of being 
> ported to KDE4.
I'm glad to know it - it's quite a nice piece of software and I would
regret if it disappear from Debian.

> Until then I would imagine you need to decide which you wish to have kipi0 or 
> kipi6 applications.
But you can make life somewhat easier for users during transition time.
I've found that only conflicting files in libkipi0 and libikipi6 are icons.
Those icons are looking the same. So, for limited period of time (until
libkipi0 application are ported to KDE4) icons from libkipi0 could be
removed and libkipi0 could depend on libkipi6.
Well, I know it's a little dirty hack, but I believe it could be used
for some time.

Best regards

More information about the pkg-kde-extras mailing list