[Pkg-libvirt-maintainers] Bug#510235: Bug#510235: libvirt-bin: virt-manager unable to connect to libvirtd as r/w (full VM management) on a local connection

Miguel Enrique Cobá Martínez miguel.coba at gmail.com
Tue Dec 30 23:08:57 UTC 2008

Miguel Enrique Cobá Martínez wrote:
> Guido Günther wrote:
>> I'm using the same setup and it works fine here.
>> On Tue, Dec 30, 2008 at 12:22:04PM -0600, Miguel Enrique Cobá Martínez 
>> wrote:
>>> unix_sock_group = "libvirt"
>>> unix_sock_rw_perms = "0770"
>>> auth_unix_ro = "none"
>>> auth_unix_rw = "none"
>> It seems you can't access the rw socket.
>> You can also try:
>>   cat /var/run/libvirt/libvirt-sock
>> It should give "cat: /var/run/libvirt/libvirt-sock-ro: No such device or
>> address" not "permission denied".
>> [..snip..]
>>> Verify that the libvirtd daemon is running with the default config:
>>> # ps ax| grep libvirtd
>> No output here? This is wrong.
>> [..snip..]
>>> You can only see the VMs (R/O mode: monitoring VM status only). That 
>>> is, you cannot start/stop/pause the VM (R/W mode: full VM 
>>> management). In the previous version you could.
>>> Now, as root, and using virsh you can start and stop the VM:
>>> laptop:~# virsh start WindowsXP
>>> Domain WindowsXP started
>>> laptop:~# virsh shutdown WindowsXP
>>> Domain WindowsXP is being shutdown
>>> The VM start and stop correctly and I can view it and use it with 
>>> virt-manager (in R/O mode)
>>> But as normal user you can't start it:
>>> miguel at laptop:~$ virsh start WindowsXP
>>> Cannot set group when not running as root
>>> libvir: QEMU error : Domain not found
>>> libvir: QEMU error : Domain not found
>>> error: failed to get domain 'WindowsXP'
>> Try "virsh -c qemu:///system".
>>> Another thing I noticed, the previous version used to start the 
>>> dnsmasq automatically (I had ENABLED=0 in /etc/default/dnsmasq). This 
>>> versión doesn't start dnsmasq and therefore denies network 
>>> capabilities to the VMs.
>> This again is an indication that you're mixing access to qemu:///system
>> and qemu:///session.
>> Please make sure you use either --connect=qemu:///system (connect to
>> daemon started via /etc/init.d/libvirt-bin) or --connect=qemu:///session
>> (started as user) and retest with virsh and virt-manager.
>> Which version of virt-manager is this? I'm using 0.6.0-6.
>> Cheers,
>>  -- Guido
> I have temporaly enabled unstable (sid) on my /etc/apt/sources.list and 
> installed virt-manager from sid with:
> laptop:~# aptitude install -tsid virt-manager
> This installed
> virt-manager 0.6.0-6
> virtinst 0.400.0-7
> using this versión of virt-manager, all worked right.
> Maybe the versión from testing (lenny) has some kind of incompatibility 
> with the libvirtd version 0.4.6-10.
> So it appears that fast tracking virt-manager 0.4.6-10 from sid to lenny 
> solves this problem.
> I continue testing for further problems, but in the meantime I can 
> start/stop/pause the VM without problem.
> Thank you very much Guido.

Well, finally all is working OK. This is what I did, but I'm not sure if 
it was the restart or the upgrade of the packages what solved the problem.

1. Enabled again sid on /etc/apt/sources.list

2. Reinstall all the packages from sid:
  # aptitude update && aptitude install -t sid kvm virt-manager\
     libvirt-bin libvirt0 virtinst dnsmasq dnsmasq-base

  This only update the versions from dnsmasq and dnsmasq-base. The other 
packages had the same version in lenny and sid.

3. Disable dnsmasq from /etc/default/dnsmasq


4. Restart the services.
    This not worked but I could see a Zombie dnsmasq proccess with ps ax.
   So I decided to

5. Restart the machine

After rebooting, all worked as before, the network is working and I can 
start/stop/pause the VMs.

Finally, these are the versions from the packages:

dnsmasq  2.46-1
dnsmasq-base 2.46-1
virt-manager 0.6.0-6
libvirt-bin 0.4.6-10
libvirt0 0.4.6-10
python-libvirt 0.4.6-10
kvm 72+dfsg-4

So, maybe rebooting the machine before upgrading the dnsmasq to the sid 
version could have fixed the problem, but I will never know.

So for now all is working right, although with the unstable versions.

Thank you very much again,
Miguel Cobá

More information about the Pkg-libvirt-maintainers mailing list