[Pkg-libvirt-maintainers] libvirt 0.4.2 backport

Laurent Léonard laurent at open-minds.org
Fri Jun 13 14:24:37 UTC 2008


I want to use Virt-manager with Debian Etch. I successfully backported 
Virt-manager 0.5.4 from Lenny to Etch. 

Now I want to backport libvirt 0.4.2 from Lenny to Etch. I know you already 
backported libvirt 0.4.0 but I want to have Xen support. So I tried to 
recompile your backported libvirt 0.4.0 with Xen support. But now I have a 
floating point exception when I try to directly connect to local Xen host 
with Virt-manager. I tested with Virt-manager 0.5.4, 0.5.3 and 0.4.0, same 
problem. So I think the problem comes from libvirt. 

I started to backport libvirt 0.4.2 frome Lenny to Etch, I disabled the 
PolicyKit support for now. But now I have an other problem, the compilation 
process seems to stop with an error message about ULLONG_MAX constant. I know 
it's in limits.h and only available (with GCC) with C99 standard. So how can 
I set -std=c99 in the package building system ? How have you solved this 
problem ?

Thank you, 
Laurent Léonard
Clos 't Hof ten Berg, N°8
B-1090 Bruxelles (Jette)
E-mail / Jabber : laurent at open-minds.org
MSN : loulou at planetcspj.net
GSM : (+32) 0476/64.83.34
Site : www.open-minds.org
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part.
Url : http://lists.alioth.debian.org/pipermail/pkg-libvirt-maintainers/attachments/20080613/38274bed/attachment.pgp 

More information about the Pkg-libvirt-maintainers mailing list