[Pkg-lustre-maintainers] Status of 1.6.2 packaging?

Niklas Edmundsson Niklas.Edmundsson at hpc2n.umu.se
Wed Sep 12 09:29:05 UTC 2007

On Sat, 8 Sep 2007, Goswin von Brederlow wrote:

> A simpler way is to use svn-buildpackage. You have to checkout trunk
> and cd to it and then just run svn-buildpackage with the same
> arguments you would give to dpkg-buildpackage.

OK. I went the svn-buildpackage route, with:
svn-buildpackage --svn-ignore -rfakeroot -ksysop at hpc2n.umu.se -tc -sa

However, I'm getting this a bit into the build process:

dpkg-deb: parse error, in file `debian/lustre-dev/DEBIAN/control' near 
line 6 package `lustre-dev':
  `Depends' field, reference to `lustre-utils': error in version: 
version string is empty

And debian/lustre-dev/DEBIAN/control has:
Depends: lustre-utils (=  )

as opposed to debian/control:
Depends: lustre-utils (= ${binary:Version})

Any ideas on why? As this is on Ubuntu Dapper, might the reason be 
that the packaging uses some feature not present in the debhelper etc. 
utils? Suggestions on workaround(s)?

I'm slightly unclued on the finer details of debian packaging, so 
please bear with me ;)

  Niklas Edmundsson, Admin @ {acc,hpc2n}.umu.se     |    nikke at hpc2n.umu.se
  "I am a Jedi, like my father before me." - Luke

More information about the Pkg-lustre-maintainers mailing list