Bug#567014: multipath-tools-boot: dm-emc is history

Guido Günther agx at sigxcpu.org
Wed Jan 27 14:43:32 UTC 2010

On Wed, Jan 27, 2010 at 03:00:05PM +0100, Ferenc Wagner wrote:
> severity 567014 minor
> thanks
> Guido Günther <agx at sigxcpu.org> writes:
> > On Tue, Jan 26, 2010 at 06:02:06PM +0100, Ferenc Wagner wrote:
> >
> >> message during boot, as this module isn't present in the current
> >> 2.6.32-trunk kernel, it's replaced by scsi_dh_emc (and co) if I
> >> see it correctly.  Please correct the hook script.
> >
> > Good catch! IMHO we should keep the old stuff for old kernels and all
> > the handlers from drivers/scsi/device_handler. Care enough to send a
> > patch?
> Hi Guido,
> Thanks for the prompt response.  Actually, the SCSI device handlers are
> included in the initramfs nevertheless, probably as a consequence of the
> MODULES=most default in initramfs.conf, so that isn't an issue.  Do you
But you need to explicitly load them, don't you? 

> think it's a good idea to support kernels already retired from unstable?
Yes since makes backports to Lenny, etc. much easier. Also people might
update multipath-tools first and then the kernel (although this probably
won;t happen due to udev requiring a fairly recent kernel).
 -- Guido

> This issue is mostly cosmetic now.

More information about the pkg-lvm-maintainers mailing list