Bug#408528: iceape-browser: Indic scripts not rendered properly

Mike Hommey mh at glandium.org
Mon Jan 29 20:44:09 CET 2007

On Mon, Jan 29, 2007 at 04:25:59PM +0100, Jan Willem Stumpel <jstumpel at planet.nl> wrote:
> Mike Hommey wrote:
> > Mine is en_US.UTF-8. Note that I didn't have ttf-indic-fonts
> > installed until recently, and the result was still the same
> > when it was not installed.
> > 
> > Mike
> I am somewhat red-faced now -- just realised I still had
> MOZ_DISABLE_PANGO=1 in /etc/environment (because of my earlier
> experiments with MATHML). After removing this, I got good CTL
> *display* in iceape and iceweasel.
> Not the *printing* though.

The printing backend is a different one.

> And now MATHML *display* is broken
> again. Both in iceape and iceweasel.

This is a known issue. While CTL support is better with pango, MathML
support is retarded.

> Can you print CTL correctly? In my case the CTL print _preview_ is
> correct, but the actual print is not. "Print preview" and "print"
> seem to do different things.

Preview is AFAIK based on the same backend as the one for display, while
print is handled by a separate backend. Though there are some things
that are different between printing from xft and printing from pango
(IIRC from bug reports we got), but I don't know the details.

I have a good and a bad news for you. The good news is all that will be
changed and a unique backend will be used for everything, even windows.

The bad news is that it's not going to happen before version 3.0.


More information about the pkg-mozilla-maintainers mailing list