Bug#561515: After last system update iceweasel do not start (Crash)

Flamarion Jorge jorge.flamarion at gmail.com
Sat Dec 19 16:37:06 UTC 2009

Hash: SHA1

> Well if you have a proper xulrunner-1.9.1 which debsums seems to
> indicate, there is no reason it should be trying to resolve the 
> g_type_class_unreb symbols.
> objdump -T /usr/lib/iceweasel/xulrunner/libxul.so | grep g_type_class_unreb
> should be returning nothing, and I expect it to do so on your system
> considering the information so far.
> That seems to indicate the error message is a lie, and the problem is
> in another library.
> Can you try running with the following environment variables set:
> LD_DEBUG=all
> LD_DEBUG_OUTPUT=/some/file
> Once you got the log, please gzip/bzip2 it and send it here.

I do not know if it was to make a difference in this situation, but I
did the following steps and iceweasel returned to work.

delete the only existing profile.
removed all the packages iceweasel
reinstalled only iceweasel. the unstable.
in the following section installed iceweasel-gnome-support. Also the
far worked perfectly.
so I installed the language package, also from the unstable, returned
the same error.
removed the package of language, and now is working perfectly.

In this process, I realized that the language packs, and
iceweasel-gnome-support have different versions, even in unstable

But before all that, I did the tests you suggested, and the system
behaved as you predicted ·

The result of the installed packages, and leaving the iceweasel work, is

flamarion at arvore:~$ dpkg -la iceweasel*
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Nome                              Versão
ii  iceweasel                         3.5.5-1
lightweight web browser based on Mozilla
un  iceweasel-beagle                  <nenhuma>
(nenhuma descrição disponível)
un  iceweasel-dbg                     <nenhuma>
(nenhuma descrição disponível)
un  iceweasel-dom-inspector           <nenhuma>
(nenhuma descrição disponível)
un  iceweasel-firegpg                 <nenhuma>
(nenhuma descrição disponível)
ii  iceweasel-gnome-support           3.5.6-1
Support for GNOME in Iceweasel
un  iceweasel-l10n-pt-br              <nenhuma>
(nenhuma descrição disponível)
flamarion at arvore:~$

In conclusion, I believe that the problem was with the package of
language, but as I do not know the relationship, because I am only User
of the system.

- --
Flamarion Jorge
OpenPGP Key: 6CA750E1
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the pkg-mozilla-maintainers mailing list