Bug#651490: Scrolling on Stackoverflow leads to high Xorg CPU usage, and large lag

Anthony DeRobertis anthony at derobert.net
Fri Dec 9 02:06:22 UTC 2011

Package: iceweasel

Version: 8.0-3+b1
Severity: important

When I visit http://stackoverflow.com/ and hit page down, it takes
around a second to respond—during which time Xorg is pegged at 100% CPU.
I tried upstream's (Mozilla's) x86_64 build, and this does *not* occur.

So something specific to the Debian build causes this.

CPU is Athlon64 4400+. Video is GeForce 7600 GT with nVidia proprietary
drivers (290.10-1). Using E16 window manager, compositing is off.
nVidia TwinView is in use, two LCDs, each 1600x1200.

There is an xtrace of a single page-down on Pastebin
There is a SE question on this at http://unix.stackexchange.com/q/26234/977

Mozilla amd64 builds can be found at
since they seem to like to hide them.

-- Package-specific info:

-- Addons package information

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing'), (130, 'unstable'), (120, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.1.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages iceweasel depends on:
ii  debianutils         4.0.4     
ii  fontconfig          2.8.0-3   
ii  libc6               2.13-21   
ii  libgdk-pixbuf2.0-0  2.24.0-1  
ii  libglib2.0-0        2.30.2-4  
ii  libgtk2.0-0         2.24.8-2  
ii  libnspr4-0d         4.8.9-1   
ii  libstdc++6          4.6.2-5   
ii  procps              1:3.2.8-11
ii  xulrunner-8.0       8.0-3+b1  

iceweasel recommends no packages.

Versions of packages iceweasel suggests:
ii  libgssapi-krb5-2                        1.9.1+dfsg-3
ii  mathematica-fonts [ttf-mathematica4.1]  13          
ii  mozplugger                              <none>      
ii  ttf-lyx                                 2.0.1-1     
ii  ttf-mathematica4.1                      13          
ii  xfonts-mathml                           4           

Versions of packages xulrunner-8.0 depends on:
ii  libasound2                   
ii  libatk1.0-0               2.2.0-2                
ii  libbz2-1.0                1.0.5-7                
ii  libc6                     2.13-21                
ii  libcairo2                 1.10.2-6.1             
ii  libdbus-1-3               1.4.16-1               
ii  libevent-2.0-5            2.0.16-stable-1        
ii  libfontconfig1            2.8.0-3                
ii  libfreetype6              2.4.8-1                
ii  libgcc1                   1:4.6.2-5              
ii  libgdk-pixbuf2.0-0        2.24.0-1               
ii  libglib2.0-0              2.30.2-4               
ii  libgtk2.0-0               2.24.8-2               
ii  libhunspell-1.3-0         1.3.2-4                
ii  libjpeg8                  8c-2                   
ii  libmozjs8d                8.0-3+b1               
ii  libnotify4                0.7.4-1                
ii  libnspr4-0d               4.8.9-1                
ii  libnss3-1d                3.13.1.with.ckbi.1.88-1
ii  libpango1.0-0             1.29.4-2               
ii  libpixman-1-0             0.24.0-1               
ii  libreadline6              6.2-8                  
ii  libsqlite3-0              3.7.9-2                
ii  libstartup-notification0  0.12-1                 
ii  libstdc++6                4.6.2-5                
ii  libvpx0                   0.9.7.p1-2             
ii  libx11-6                  2:1.4.4-4              
ii  libxext6                  2:1.3.0-3              
ii  libxrender1               1:0.9.6-2              
ii  libxt6                    1:1.1.1-2              
ii  zlib1g                    1:       

Versions of packages xulrunner-8.0 suggests:
ii  libcanberra0      0.28-3  
ii  libdbus-glib-1-2  0.98-1  
ii  libgnomeui-0      2.24.5-2

-- no debconf information

More information about the pkg-mozilla-maintainers mailing list