Bug#496133: fixup version.sh to include a meaningful version in the ffmpeg binary

Reinhard Tartler siretart at tauware.de
Fri Aug 22 21:01:23 UTC 2008

Package: ffmpeg-debian
Severity: important

22:51:53 <@DonDiego> i patch the version.sh script in the tarball creation script
22:52:02 <@DonDiego> so that a proper version number is generated
22:52:30 <@DonDiego> siretart: your package should identify itself as FFmpeg-r1234567-debian or something
22:53:00 < astrange> oh, it's for old codecs that just draw on top of themselves
22:53:58 < siretart> DonDiego: okay, I'll do that on the next svn bump. I intend to work on that next
22:54:19 <@DonDiego> siretart: please put it at the top of your todo
22:54:27 <@DonDiego> that's important for us
22:56:41 < siretart> hm. it doesn't happen with current svn.
22:56:56 <@DonDiego> bingo
22:56:58 < siretart> seems that I'll update the package and then revisit that issue
22:57:02 <@DonDiego> siretart: look at version.sh
22:57:08 <@DonDiego> NEW_REVISION="#define FFMPEG_VERSION \"SVN-r14903\""
22:57:16 <@DonDiego> you just need to patch this line
22:57:49 <@DonDiego> ummm
22:58:08 <@DonDiego> that was the version.sh from the svn export snapshot
22:58:19 <@DonDiego> anyway, it should be pretty trivial
22:59:01 < siretart> how about '#define FFMPEG_VERSION \"debian/ubuntu package revision0.svn20080206-11\"'?
22:59:18 <@DonDiego> for example

-- System Information:
Debian Release: lenny/sid
  APT prefers hardy-updates
  APT policy: (500, 'hardy-updates'), (500, 'hardy-security'), (500, 'hardy'), (70, 'hardy-proposed'), (50, 'hardy-backports')
Architecture: i386 (i686)

Kernel: Linux 2.6.24-19-generic (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

More information about the pkg-multimedia-maintainers mailing list