Bug#490319: ffmpeg2theora: FTBFS: ld: cannot find -ldc1394_control

Reinhard Tartler siretart at tauware.de
Mon Jul 14 07:57:58 UTC 2008

Fabian Greffrath <greffrath at leat.rub.de> writes:

> Hi all,
> Reinhard Tartler schrieb:
>>> It looks like the dependencies of libavdevice-dev are a bit messed up
>>> as follows:
>>>  - libavdevice-dev Depends on libavdevice52
>>>  - libavdevice52 Depends on libdc1394-13 (*Note*: not libdc1394-22)
> WTF? Why does libavdevice52 depend on the old libdc1394 library although
> the new one is listed first in the Build-Depends?!
>>>  - the file /usr/lib/pkgconfig/libavdevice.pc that ships with
>>>    libavdevice-dev should not explicitly add -llibdc1394_control
>>>    to the build flags.
> Right. This should happen automatically in ffmpeg's configure script in
> lines 1656ff. However, the Debian package seems to have built against
> the old lib - which is highly unexpected - and pulls in the new lib as a
> dependency for the libavformat-dev package.

Okay, now I found it. In my build chroot, libdc1394-13-dev was
installed. This is of course something I didn't expect, but shows that
the current situations wrt build-depends is too fragile. I wanted to
make it easier for backporting the package, but if that means that we
provoce bugs like this (which I didn't forsee) I'd suggest that we
depend explicitly on libdc1394-22 and Build-Conflict against the older
libs. In case of backports, that diff has to be maintained. 

Reinhard Tartler, KeyID 945348A4

More information about the pkg-multimedia-maintainers mailing list