add epoch '3:' to ffmpeg-debian, was: Bug#482894: Please, open again the bug

Fabian Greffrath greffrath at
Thu Jul 17 08:05:17 UTC 2008

Reinhard Tartler schrieb:
> Why that? The conflicts are all versioned and only bound to the current
> package version. Having them like this in debian wouldn't hurt AFAIS.

This is for libavutil-dev:
-Conflicts: libavformat-dev (<< 0.cvs20060329-4),
+Conflicts: libavformat-dev (<< 3:0.cvs20060329-4),

and this is for libavformat-dev:
-Conflicts: libavcodec-dev (<< 0.cvs20060306-1),
+Conflicts: libavcodec-dev (<< 3:0.cvs20060306-1),

Neither libavformat-dev (<< 0.cvs20060329-4) nor libavcodec-dev (<< 
0.cvs20060306-1) has ever been available in Debian AFAICT.

> the only difference is really the faad dependency.

Since we don't have something like Build-Recommends in Debian (i.e. 
install if available, but do not fail if not), maybe we should add an 
alternative Build-Depends to libfaad-dev that is definitely 
installable from Ubuntu main, e.g.:
libfaad-dev | libfaad2-dev | ubuntu-core,

On the other hand, this is a very, very, very dirty hack and I am 
already ashamed that I proposed this... ;)

> for reference, the current ubuntu diff can be seen here:

I know, that's where I found it. ;)
Fortunately this link is referenced from the Debian PTS page.

Dipl.-Phys. Fabian Greffrath

Ruhr-Universität Bochum
Lehrstuhl für Energieanlagen und Energieprozesstechnik (LEAT)
Universitätsstr. 150, IB 3/134
D-44780 Bochum

Telefon: +49 (0)234 / 32-26334
Fax:     +49 (0)234 / 32-14227
E-Mail:  greffrath at

More information about the pkg-multimedia-maintainers mailing list