Problem with ffmpeg-free

Reinhard Tartler siretart at
Sat Mar 29 23:22:02 UTC 2008

Christoph Pleger <Christoph.Pleger at> writes:

> Hello,
> the attached diff file contains all differences between the lenny version of 
> ffmpeg-free and a working Ubuntu version of ffmpeg, except the differences in 
> the /debian-subdirectories. Applying that patch to the lenny-version of 
> ffmpeg-free solves my problem with the dvdstyler-Software.
> It seems to me that in contrast to Ubuntu some encoders have not been enabled 
> in Debian, is there a reason for that?

Oh, the patch you have found is more or less pretty much what the
debian/ does strip off patented encoders. The debian archive
administrators do not accept mpeg related encoders, so we had to strip
them for for debian.

Obviously dvdstyler relies on the availablitly of a specific mpeg2
encoder, which has been disabled for debian. Unfortunately, it does not
check if that codec is actually available, but just crashes. Which is a
pitti :(

btw, would you please tell me which version of the ubuntu ffmpeg you
were comparing against?

Reinhard Tartler, KeyID 945348A4

More information about the pkg-multimedia-maintainers mailing list